MKV Audio and Video Issues - Track Compression


#1

I know there’s a lot of people having problems with audio not working with MKV files on their WD TV Live Media Players, and a great majority of them appear to be related to the track “compression” feature of mkvmerge v4.1.x and above.  Well, it hasn’t really been mentioned anywhere else, but the track compression issue also effects video tracks as well.

I typically add chapters and various audio tracks to my Xvid files, and noticed that Xvid files muxed into MKV containers don’t play in WD TV Live players (version 1.03.29_B).  The video starts to play, and begins skipping really fast through the video for a few seconds, then freezes.  x264 video tracks work fine (which is probably what most people download… errr, buy).  It appears to be isolated to Xvid (though I have not tested others, e.g. OGV, mpeg2, etc. 

There’s a lot of advice being thrown around, with people suggesting to downgrade to earlier versions of mkvtoolnix, to others saying you have to “reencode”, which is probably just a misnomer for remux.

To “fix” both the audio and video issues, until WD fixes their firmware, just use the latest version of mkvmerge and remux the original MKV file to a new MKV file while disabling track compression.

From CLI:

mkvmerge -o new.mkv -1:compression none original.mkv

The “-1:compression none” disabled compression on all tracks.

From GUI:

Highlight each track, go to “Extra Options” tab… and use the drop down menu labeled “Compression” to specify “none”.  Do this for all tracks… including BOTH Video and Audio.

The resulting audio tracks and Xvid video tracks should be playable in the WD TV Live Players.


#2

or just use version 4.0.0 of MKVmerge which is much easier.