Missing Virtual CD on My Passport USB3


#1

I have a new My Passport Essential (USB 3.0) 1 TB drive. When I connect it to a computer, no virtual CD appears; there is software installer packages on the main drive itself. This is a problem because I need to turn on encryption and be able to connect to other computers. This is normally accomplished with the unlock program on the VCD. Is there any way to turn the VCD on? The instructions indicate it should be there.

Thanks,
Chris


#2

No problem freind here is a link to the download of the smartware software especially made for the 3.0 you have

http://www.wdc.com/wdproducts/wdsmartwareupdate/Step1.asp?id=wdfMP30_Essential&os=WIN


#3

Thanks for that, but what I really need is the vitrual CD with the unlock app on it.  I don’t want to and can’t install SmartWare on every computer I ever connect this drive to.  I use to to backup files from and install programs on other people’s computers.


#4

I thought of this when Lawrence posted a link to Smartware & Firmware for your drive.  Then I thought it is best to wait for your response…

This zip file will give you all the files you need to put in to your drive…

My Passport Drive Contents: Windows

http://download.wdc.com/smartware/WDSmartWare_PP4R2_1_4_1_2.zip

My Passport Drive Contents: Mac

http://download.wdc.com/smartware/WDSmartWare_Mac_Disk_Image_PP4R2_1_3_0_18.dmg

Unlock.exe is also included in this package


#5

Thanks.  The software will be helpful, but it won’t actually solve the root problem.  I can store these files on the drive itself, but if it is locked with the password and I take the drive to another computer, I can’t access the told because the drive is locked.  As much as people hate it, the nice part about the virtual CD is that the utilities and unlock.exe are always accessible even when the main drive is password protected.

Does anyone know if the virtual CD is supposed to be working on this drive?  The documentation indicates that it should.

Thanks,

Chris


#6

All My passport drives supposed to be equipped with VCD. You can use this utility to make VCD visible if it is hidden for some reason. If this won’t work means your drive doesn’t have VCD preinstalled.

http://download.wdc.com/smartware/WDSmartWareVirtualCDManagerforWindows-v1.0.7.4.zip

VCD portion of software already available in the zip package I ask you to download. Take a closer look at the zip file contents and copy folders and files to root of you WD drive. One done you’ll have to recycle power to the drive.

I now gather that WD is now issuing new replacement drives without VCD or Smartware. I cannot confirm this. So please be tolerant.  It seems that they are fed up with elevated amount of complaints related to password lock (VCD) and Smartware.  


#7

Thanks again for the info and software links. I did try the VCD manager; it did not detect any compatible drives even after the latest firmware update.  Even SmartWare doesn’t show a VCD management option for this drive like it does with some My Books bought late last year.

If WD has started completely removing the VCD from drives, especially the portable ones, that **bleep**.  It makes the drives much less useful and contradicts the documentation that ships on the drives.  The chief (and only real) benefit of the Virtual CD is that it kept the utility software available, especially the UNLOCKER, even if the main drive was locked with a password making it very easy to use the drive on a guest system.  Now you must download and install the WD SmartWare on any guest computer. or at least go online to download the unlocker or carry it on a separate disk?  That’s crazy.


#8

It turns out that the Virtual CD only contains the Unlocker tool now and will only become visible/mountable once a password has been set on the drive.


#9

Has the problem been solved?

I also have a wd external hard drive.

When I first used it my drive could only be accessed via wd software and it was secure.

Now when I plug in, I can access it via start, computer.  but not via the wd software?  My data is no longer secure.

Maybe I’ve un installed part of the wd software, the virtual cd?  would that account for it, if so how do I re install it?

i tried re installing the whole of the wd software but that hasn’t helped.

Thanks

Gail


#10

If your VCD is invisible, use this utility to make it visible again. Extract and run Virtual CD Manager.exe.

Hide/Unhide VCD

http://download.wdc.com/smartware/WDSmartWareVirtualCDManagerforWindows-v1.0.7.4.zip