Missing Video Files

Just wanted to ask why some video files are missing from my list (either via the Video or Files tabs)… I noticed at least 2 files suddenly vanished after I upgraded to the latest firmware. Likewise, even before updating my system, I was trying to look for another file/folder  that I was certain I saved but couldn’t find after reviewing my video list. I just initially shrugged it off as someting that I must have missed, and that my memory wasn’t serving me right. But last night, I tried to move a file using the TV Live Hub system, and when I got to the portion where I had to choose in what folder to save the file, among the choices, my missing folder was part of the option… I was after all able to save it from the very start. But whenever I get back to my main video list, I couldn’t fild either the folder or the file. Any update remedy for this? or do I have to do something to totally view the contents of my drive?

On another note, though really minor but may be worth mentioning, I have a single file saved in a folder, so I thought it would be better if I just move it out of the folder and just put it in the main video list. The moment I did it, the folder disappeared… which should not be a bother as I have no use for the empty folder anymore anyway. But I just thought it would be much proper that I am allowed to delete the folder myself, as I have a feeling the folder is just scattered somewhere in my disk. Likewise, when I tried to get info on the moved file, that option wasn’t no longer around and I couldn’t update my file info anymore. So I tried moving back the file, the missing folder showed up in the ‘where to move’ option… did transfer back the file to the folder, and got to update my file info again. I just find it weird that I cannot empty a folder and delete the empty folder, so much so, update info of the file that got transferred back to the root listing of the video files. Thanks!

That sound like a strange behavior with the firmware. In order to verify if it was the firmware update that caused the chage I would suggest you roll back the firmware. The file should appear if it was in fact the firmware issue take a look at the link below

http://wdc.custhelp.com/app/answers/detail/a_id/5860/session/L3RpbWUvMTMwMTUxMzAxMS9zaWQvNk5TZDRmcWs%3D

Regarding your second issue of disappearing folders  (after you delete files), that sounds like what will happen if you delete all files that the hub can play or display from a folder … eg, if there is no image, video or music file left in the folder that the Hub can recognize, it will ignore the folder (except, as you have discovered, when trying to find a place to move or copy another file).  The best way to see your folder/file structure is from your computer viewing the HUB as a network drive.  

Regarding your first issue of disappearing files, the HUB is a mysterious and temperamental mistress, I have found.  With patience, humility, creativity and serious pampering (and using the forum) you will find workarounds for most though not all of her quirks and tantrums.  (in other words, I don’t know, except, again, to recommend that you investigate the HUB as a network drive using your computer). 

So, I think there might be a workaround for your issue.  Here’s what’s happened to me:

My firmware version: 2.05.08 .

I populated my WDTV with tons of music when I first bought it and all worked great.  I mapped the WDTV to my Z:\ drive, and I could add and remove files whillly-nilly.  This was fine when using the WDTV as a newok drive.

However, when accessing these files directly on the WDTV on my TV, a lot of recently added files would be missing!  There is no option to rescan or anything else.

Finally I figured out a wokaround to rebuild the index file on the WDTV.

Home Screen -> Setup -> System -> Media Library -> Clear Media Library

It will take a litle while, but all the directories seemed to show up

Thanks to the replies! Tried this re-population technique… files did show up… really much appreciated :slight_smile:

Thanks for this. I was having a similar issue and clearing the media library worked like a charm.

Kudos! Roughly 75% of my movie titles all of a sudden went missing last night. Clearing the media library worked like a charm. Thanks !

Me too and it fixed it! Legend.

Not so fast with this solution… I too have been experiencing video files/folders that disappear when viewing via WD TV Hub (1 ter drive built in). When going to my computer to view the media player via network, sometimes it’s still there, sometimes it isn’t. I have discovered that WD media player seems to take the liberty of tagging a file as corrupt/unusable and doesn’t list it in it’s directory. For instance, I had a home movie I pushed via network connection to the media player. When viewing the movie (15 minutes into it), the movie stopped by itself (video paused) but the audio continued… I then exited to the home menu and re-entered the folder to discover the file is missing! Reboots don’t help either. Firmware has always been updated as soon as an update is available. Clearing the media library as suggested does not bring back my missing files. It sometimes will re-list a folder that didn’t show up before. But hasn’t brought back any file that disappeared! This concerns me greatly. I want to trust my WD TV Hub as a safe, dependable unit to store my media. Yes I have another copy of these files but it’s unacceptable to be always be questioning if a media file will remain on this unit.

Can someone help me with my problem please. I transfered some avi videos from  my computer to the hub on My Y:/hub wireless connection. Whe I look in the folders in hub storage from my computer the files are showing that they are saved there. When I go into the living room and try and watch them, they are not showing in the hub local storage? What could this be?