Missing Thumbnails

I used to have a thumbnail image for all of my films and they were all working fine until a couple of weeks ago when some of them vanished.  I have so far tried removing the images and getting the unit to look them up again, clearing the image cache, removing the XML file and the image but to no avail.  The odd thing is that it doesn’t seem to effect all the images, just some of them.  Also it doesn’t seem to be the format of the image (jpg or png).  Any and all help will be greatly appreciated.


Have you updated to the newest firmware plus what theme are you using?

The updated firmware has affected some thumbs at least with the anodized trickle theme by tinwarbe and I think he said it affected all his themes

sorry for the delay…I am running the latest firmware and I’m running the Mochi theme.  Would this have any effect?

Thanks for your help


Strange enough the the same thing has happened to me, I have some of the thumbnails but most are gone and updating on the web with the " get info button"  does not help. 

Would love to know how to fix this.

bit of an update…I have just upgraded my WDTV Meta Data Download program to V2.1 and this is also missing the same thumbnails as the WDTV.  Looks like we might be finding a common link here…hope this helps someone :slight_smile:

Another revelation!!! All the films that are missing are DVD folders.  What I mean by that is the folder has Audio_TS and Video_TS folders in it and the name of the folder that they are in is the name of the film.  For example:

Disney - Aladdin - AUDIO_TS
                               - VIDEO_TS
                               - Aladdin.jpg
                               - Aladdin.xml

If this means anything to anyone I would appreciate all and any advice…


Ok, slight addition to the message…I converted the Audio and Video_TS  files from the Aladdin folder  to .iso and placed the file in the same directory as the xml and jpg files.  The result, after deleting the Audio and Video folders, a refresh of the xml and image files, a restart and a re-index was a loss of the film completely!  No folder, or image on the WD whatsoever.  Even though the WDTV Meta Data Download application now sees it my Hub doesnt :frowning:

Same for me, just my DVD folders

I’m going to drag the thunbnail (jpg) out of the dvd folder and see what happens

Looking at a dvd file via network view on the mac and then running either auto or manual Get Info  you see the correct xml and thumgen being added to the file - so not sure why its not being displayed-must be either where the files sit or their name?

Well it appears that the latest firmware has resolved the issue. i saw the upgrade last night and tested it straight away and all my thumbnails had returned. there was nothing in the change log to say it was fixed but for me at least it is now working. i just hope that for those of you who had the same issue it is also sorted. thanks to everyone who replied.

I have updated to the latest fw and have this problem


The problem is better, but it’s not completely fixed.   On a handful of cases, the thumbs didn’t appear until after I rebooted the box.

I have been missing my thumbnails since the last 2 firmware updates, this is getting to be a recurrent issue with updates.

Why am I missing them and how do I fix it.

I’ve noticed that on all my new movies added after the last firmware update the get content info function generates a MOVIE.metathumb file instead of a MOVIE.jpg file.  As soon as I rename the .metathumb file to .jpg my thumbnails appear liek they used to.  Easy fix but such a pain to do manually every time I add a new movie.

WOW!  Really?  That is a real pain and a really bad way to provide a product to the customer.:mansad:

Well I tried that and no that did not work, I have over 250 moves now that do not have a Thumbnail, very disapointing after all the work I had to go through to get them on the drive in the first place.

I just reverted back to 2.07.17 firmware and my movie icons (thumbnails) are back so there is definitely a problem with the Firmware revision as it all starated with 2.08.13

Sorry to not have replied to your messages, I still have problems, not so much with icons now but with it playing rips of dvd’s (those with AUDIO and VIDEO_TS)  It simply wont play any of them.  I’m not sure if its where I’ve changed my nas and somehow changed the link to it or some other way I’ve messed up but my faith in the wdtv livehub is certainly deminishing.  I tried to create a play list of christmas songs and that didnt go according to plan either.  Still thats for another message.  I hope WD read these messages as I am thinking of going back to a previous firmware as both me and my family knew that we were able to get images, play files and do what we wanted with most things without it breaking.  I wonder if WD’s QC are on a Christmas break ;-)  Ah well, rant over.  any further movement, let me know…