I’ve received my WD TV today (The Netherlands)

Everything works for now, except the miracast part.

When i want to connect my samsung S4 through 'Screen Mirroring", the WD TV says after a few seconds that there was a sudden connectionstop due bad connection. Even when i put my cell like a inch away from the WD, the same connection error occures.

I’ve tried it both ways, while the WD TV was connected to the wifi and also when it was connected through a lan cable.
Also the “Device Paring in Push Button Mod” options Manual or Automatic gave the same results.

It stops connecting even before pressing any pin code, like the WD TV Manual says.

any ideas whats wrong? on my end or the WD end?

Sadly i cant try miracast out on any other device besides my S4.at the moment. (got another problem with my laptop wich stopped working with WIDI suddenly :S)

I hope i was clear enough and thanks for your reply in advance

Hi KLensink, try pressing the WD TV reset button. If the issue continues, I recommend you to contact support directly. 


1 Like

I think i found the issue. I changed the workgroup into the same as my other devices, like my laptop and pc.
When i change it back to the default WORKGROUP, my samsung s4 can connect with miracast without any problems.

But i need the other workgroup to see my shared folders.
Very annoying though!

Having the same identical issue (Samsny s4 with kitkat, WDTV Live).  Tried all previously mentioned “fixes” (i.e. manual vs auto, 2.4Khz only, reset both phones and WDTV). Also tried the WORKGROUP trick to no avail, didn’t think that has anything to do with it and was suprised that it worked for the original poster.

My setup is not anything unique, so I’m puzzled as to the reason it does not work right from the getgo.  Any other ideas?  Seems to connect just fine via WiFi Direct, but no go with miracast.

KLensink wrote:
I think i found the issue.

Hardly. Changing the workgroup “reset” the network on those devices so this was some kind of workaround to get it done. Question remains why it happens in the first place.

I had the same proplem when switching the WDTV from wireless to wired.  Went to settings and removed the stored wireless setting, rebooted WD and it was back to working.

With the WDTV over wired ehternet, Miracast will not work. Found this in another post.

nsystems wrote:

With the WDTV over wired ehternet, Miracast will not work. Found this in another post.

Not Correct

Miracast works fine with a wired ethernet cable plugged in.

See the little Red Cable in this picture ?