Mionet restarting on it's own


#1

Hello all,

I am noticing that Mionet keeps re-enabling itself, so when I go into Configuration and click “Stop Mionet” and untick “Enable Mionet on Startup” … about 15mins later, I go back and check, and the Mionet status says it is “Started”.

I read here… http://mybookworld.wikidot.com/forum/t-203006/solved … that you can go edit some stuff through SSH, which seems like a pretty good idea and would solve my problem, but I have like 700 days on my warranty, and I don’t want them void by me accessing it through SSH… so my question is… will it void my warranty, and does anyone have any other solutions.

Thanks in advance

Jordan


#2

I have been waiting on WD to fix this BUG long 9 months, then I fix it by myself.

completly guid

http://community.wdc.com/t5/My-Book-World-Edition/Drive-Becomes-Un-Accessible-After-short-use-II/td-p/38659

I have uptime now 9 days and the problems are gone.


#3

Hello Vlado,

Thanks for the reply, will following the steps in that link void my warranty, as I don’t exactly want to loose about 700 days of warranty LOL.

Cheers

Jordan


#4

You will not lose your warranty, anyway when WD will release new firmware, old firmware and configuration will be replace…


#5

Ahh cheers buddy, I will give it a try tonight and let you know!

Jordan


#6

Hey buddy, I followed the top part of your tutorial using Putty, but the last bit is the bit I want, the bit that says “for the experts:” … how to I edit that “.sh” file?

Cheers.


#7

You don’t need to use this part, becouse you totaly disable Mionet with the previous steps.

This part only fix the problem for users, which would like to use Mionet and only somtimes disable it.

What is your uptime?


#8

Sorry I have done this the completely wrong way around, I do occasionally wish to use mionet for work etc, but at the same time want to fix the bug where it restarts automatically.

So I guess I now need to somehow restore mionet and do the second part instead, is that possible, so to restore it via putty and teach me how to do the second bit? Sorry for being such a douche, I have never done this before LOL.

Thanks

Jordan


#9

Also, I don’t even know if I done the first steps right LOL… all I did was is opened putty, and I copied and pasted each individual line and hit enter. Don’t know if it worked because it hasn’t gone into standby yet LOL.

Jordan


#10
  1. Stand by Mode - do it true amdministrator console - WD discovery - Configure - login (admin/admin) - Advanced mode  - Advanced - HDD Standby Enable

  2. chech if Mionet is Disable - WD discovery - Configure - login (admin/admin) - Advanced mode - Network - Remote Access - Status STOPPED

I recomend you, if you have old firmware 1.1.16 or 1.1.18 to totaly disable Mionet and Twonky (you did it now), becouse you will restart manualy the WD MBWEII every ± 20 minutes when you make bigger data transfer (5-10 GB). problems with Buffer leak and in firmware, … You will be crazy with this situation and the device will be not possible to connect from outside, becouse it will be not accesable.

  1. if you would like reverse the porcess just use this this lines…

mv  /root/S9M_mionet /etc/init.d/

mv  /root/S97twonkyserver /etc/init.d/

mv  /root/cvm /usr/mionet/bin/

mv  /root/changeNotifySocket /usr/mionet/

mv  /root/miocrawler /usr/mionet/plugin/miocrawler/

then reboot your NAS with

reboot

My advice is disable Mionet and Twonky and push on WD to release new firmware, then you can enjoy your NAS with full functions :slight_smile: