Milestone Arcus Surveillance does not install on my NAS EX4100

I just bought the new WD NAS EX4100,
but if I try to install the application Milestone Arcus on my NAS, the system after 30 minutes for download, the NAS shows me a message saying “Error: Failed to install app.”

The NAS is new and empty, I have only one drive HDD 1TB installed and the status is ok.

Today I have installed also the new firmare (2.21.111)

Can you help me to find a solution?

Best Regards


After installing the new firmware, have you tried resetting the drive and testing that again? If not, please try that.

Hi, thanks for you response.

I have already tried to reset and re-initialize the NAS to the initial condition, but the results the same.

All other applications have not given problems, only for the Milestone Arcus I have this installation problem.

I also tried to register to the cloud and to set a static IP address, but nothing to do, the problem is not resolved.

Do you have other ideas?

Best Regards,

I downloaded the file packet (.bin) of Milestone Arcus from this link

After, I have copied the file in “Public” dir and I opened the SSH console, the result is the following:

I have resolved the installation problem. :slight_smile:

I downloaded the last version of Milestone Arcus application from this link:

and after, I have installed manual the application (.bin) using the web user interface.