Microsoft or WD? One of them is ruining my WD Internal drive!

Microsoft’s ruining my WD Internal drive! At least, I’m assuming it’s MS. It could be Western Digital that’s doing it?

The issue:

My WD HDD “activity” led flashes once-per-second as long as my computer is on. And, that happens even if I’m not logged into my user account. That is wearing-out my HDD faster than it should! I just had to buy a brand new WD HDD because the one I had (which was also WD, and was only 1-1/2yrs old) died suddenly.

I need advice:

What is causing the incessant disk activity? How do I prevent it?

If it’s software (Microsoft’s or Western Digital’s), please advise me on which software it is, or could be, and whether or not I can disable or remove such software. I’ve tried stopping Microsoft’s “Search Indexer” but it scrambled my system, and I had to restore my system to an earlier date! If “indexing” is causing the problem, then will you please advise me on the correct procedure to disable/remove the indexing function? If it’s a WD “feature,” please tell me how to stop that.

I do not want to burn-up another HDD due to this constant, unnecessary disk activity.

As far as I know the light will only blink when the hard drive is being accessed.  To disable indexing, check the link below.

Edit: Removed wrong USB advice. 

I know the "light will only blik when the hard drive is being accessed. That’s exactly what I said in my OP. The HDD LED was flashing once-per-second, every second. That means that my HDD was constantly being accessed, which I didn’t want to happen. It was wearing out my HDD unnecessarily!

What USB? Internal hard disk drives, as I specified in my original post, are not USB. External ones can be USB.

By the way, I finally got to look at the website you provided by your link. I say finally because I had to block 20 cookie requests! Geeesh! I read the info. Thanks.

However, I found a solution on another website before anybody replied on this website.

The solution I found offered 2 ways to solve the problem.

1. Open the case, remove the cables from the CD/DVD Burner.

2. Disable the CD/DVD Burner in the Device Manager.

The problem I and others were having was because some CD/DVD drives are not compatible with Windows 7 OS. Mine was one of them. Microsoft just can’t seem to supply correct drivers in many instances.

Thank you, Alucardx23 for replying!!!

I’m done with this topic.

If the DVD drive is causing the problem, I would try getting another one, you should be able to find a replacement really cheap. 

HomeBound wrote:

I know the "light will only blik when the hard drive is being accessed.  

That’s not necessarily true.

My system HD LED will blink about once every 2 seconds even when the drives are in standby.

I can tell the drives are in standby because I can hear them spin up when I go to unlock the desktop.