Metadata problem - TV show listed as movie

Phineas and Ferb! (not just for the kids) doesn’t recognize xml files I created with TonyPh’s XML fetcher, or with WDTVHubGen… nor does it work with manual ‘get info’ because it says the MOVIE database doesn’t find any matches! There is no movie called Phineas and Ferb, and there are TWO tv shows called that, so apparently the auto get info gets confused?

Why doesn’t it recognize my xml files? their names are identical to the file names, which are

Phineas and Ferb.S01E01.mp4

I also tried


same results.

What I see on the wdtv grid is the correct graphic, 20 minute duration (which is correct) and the correct description (under ‘show info’) but no series or episode name, plus they’re not in any logical order…

I don’t have this problem with other TV shows.

Did you ever figure this out?

Sort of… had to erase the media library and let it start over, with the xml’s from the fetcher, and it worked. It still doesn’t show an episode name an any of them, and they are not sorted by anything… so still some work left to do. I’d rather not go in and edit over 100 xml’s files manually, not worth the effort.

Clearly the info search needs to search both imdb and tvdb for any file, not assume it’s a movie to tv show. Also tvdb needs to improve their search function, it is useless. typing ‘Phineas’ it finds nothing. Phineas and Ferb finds two shows, one called Phineas and Ferb, and one called Phineas and Ferb take two… so A. the first search (Phineas) should have found that, and B. the second one should have found the exact match over the other, less close match.

oh well