Metadata **bleep**

I’ve been trying to correctly fetch the data for all the movies/shows on a USB drive attached to the WDTVL and have been running into some frustrating issues. Main issue is that the metadata messes up the episode order of every show it fetches info for. Instead of the eps being proper sequence like i have them (01, 02, 03, etc) they end up being like: 1 10 11 12 2 3 4 5 etc so the shows are all out of sequence which really goes against the convenience factor that is the whole purpose of me trying to get the metadata in the first place. I tried browsing to the drive on my computer and editing the hidden .xml file and changing the episode and title numbers to have “0” in front of the eps under 10, but that didnt fix it. The second problem i’m having is that when the WDTVL fetches the incorrect metadata it is hard/impossible to get rid of the wrong info. As and example, i have the Lord of the Rings movies on the drive and it fetched the data for the first two movies just fine, but for The Return of the King it fetched the data for the old cartoon movie. I went in and changed the search term and selected the right result and loaded the right info, but it still isnt right. The title/cover still shows the animated version when i select the movie, but if i hit “view info” it shows the right cover on that screen. Also, it has backdrops from the animated version mixed in with backdrops from the correct, live-action version that it keeps going back and forth between. I tried deleting the metathumb file but it was still there. I tried putting folder.jpg and a jpg with the same filename as the video file in there and still it shows that stupid cartoon version cover instead of the right one. Is there seriously no way to manually edit these things? I’m going to turn off metadata fetching altogether if its just going to mess up the order of my shows and replace the proper covers with wrong ones.

Any time you EDIT the XML, you need to clear the media library so the changes are re-imported.   Otherwise the changes are only DISPLAYED, but not used in any other function.

You can get rid of the wrong info by selection OPTIONS / CLEAR CONTENT INFO.

Then do the GET CONTENT INFO again.

They did mess up the folder.jpg function…  It now prefers the first .metathumb file it finds.   Yeah, that’s definitely annoying.  …and a bug report has been filed on that one.

If you change your folder.jpg name to folder.metathumb, it should again take preference.

Finally, you’ve posted this in the wrong forum.  The correct forum is here:   http://community.wdc.com/t5/WD-TV-Live-Streaming-Media/ct-p/wdtvlive_streaming

hey thanks for the reply man. I’m not at home right now but i’ll try that as soon as i get there. Thanks for the info and sorry about posting in the wrong subforum!

Well after deleting and rebuilding the library it did organize my episodes in the proper order according to my editing of the .xml files. It would be nice to have it automatically avoid this in the future tho by listing single-digit episode numbers with a leading zero tho. But im content with this fix. However the problem persists with the wrong content showing up for Return of the King. I just cannot get rid of that wrong cover, even though it fetches the right info. I tried renaming the folder.jpg to folder.metathumb and it still shows the wrong cover. So in the folder right now is: return of the king.mkv return of the king.jpg folder.jpg folder.metathumb all .jpg as well as metathumb show the correct cover, but still the animated cover is displayed when the movie is highlighted on the WDTV. Is it possible this cover could somehow have been embedded into the mkv itself similar to mp3 id3 info? ive never heard of such a feature for mkv, but i cant think of any other reason why it would still be holding on to that cover despite everythign ive done, unless its cached somewhere else on the WD TV and me deleting the library and recompiling it didnt get rid of it for some reason. Oh well at least i got the main issue sorted out, thanks for your help. If anyone has a solution to this wrong cover being shown tho, i’m open to suggestions to try.

Vote for this issue:

http://community.wdc.com/t5/WD-TV-Live-Streaming-Issue/Auto-scraped-TV-show-TITLES-lead-to-bad-SORTING/idi-p/305090

No, the WD won’t embed artwork in the files.  

If you have the HUB, you may need to purge the thumbnail cache.