Media Write Protected

Hello, please bear with the long story

I purchased a Elements drive a few years back.  After the warranty expired, it died, so I bought a bear WD hard drive and put it in the elements box.  Worked just fine.  Now, I’ve moved that drive into my desktop and put an older existing drive (WD 250GB Caviar Blue) into the elements case

When I booted back up, the USB was recognized however the drive did not show up.  I went into disk management and it said it needed to be formatted, I had transferred the data off previously so I clicked OK.  It came back saying the drive was write protected.  I took the drive out of the case and plugged it back in, worked again.

I tried to use Diskpart, it said it was not write protected.  I told it to remove write protection anyways and it said it failed.  I also ran the WD diagnostic and it says the drive is working just fine.

Any idea why it would work without a hitch plugged directly in, but when attached with the elements it can’t be seen in explorer and it gives a write protected error when you try to format it?



Hi, replacing the internal hard drive on a WD external drive is not supported, but maybe some of the other users can share their advice. 

So I’ve got nothing then?