Media Servers - Using Mezzmo and PlayOn - Cannot get PlayOn to actually Play-on


I have several WD TV Live boxes in my home, all network hardwired via gigabit ethernet.  All are using FW 1.09.10.  Router is an ASUS NT-R16.  Main server computer is ASUS GC-5270 quad core w/ W7 64 bit, with 8TB of internal/attached storage.

I have been using Mezzmo quite successfully for the past year as a media server instead of using network shares.  It has been very stable and easy to use.  Set up perfectly right out of the shoot.  Even my 8 year old has a good handle on getting to what she wants.

I have been wanting to try PlayOn and yesterday downloaded the free trial version to see what was up.  Mezzmo doesn’t have channels, so I wanted to see what PlayOn could do.  It downloaded fine, and the WDTV could see it fine.  I can navigate to the channels and even get maybe 5-10 seconds of one of the videos to play.  Then the media server disconnects. Often it disconnects before I finish navigating a file menu. I have tried every combination of turning off security software, including having everything off, and still no joy.  I have also played around with the PlayOn settings trying different quality levels and such.  Yet, I read that lots of people have success with PlayOn.

Any suggestions? Router settings? Security settings?

SOLVED!  Via PlayOn support.  I was using ethernet and wifi on the server computer.  Turn off the wifi and bingo!