Media Server problems

When going to the control panel, settings -> Media, you can turn on iTunes sharing and/or DLNA (Media Server).
I wanted to turn both on, but I have a lot of multimedia on my NAS. I figured it would need quite a while, but this is exaggurated I think…

I use my NAS to store my movies and series and also backup my music on it. I wanted to turn this on as it’s a usual feature but here’s what happens;

1st time.

I turn on DLNA. I was on teamspeak with a friend talking about both of our My Clouds and his works fine. I was waiting for a long time… Eventually it turned out to be around an 1h45/2h and there went the control panel.
500 - Internal Server Error.
I could see my LEDs of my NAS still flickering, meaning it’s busy, but had to restart as awesomely enough there’s no fix besides rebooting the whole system.

System reboots. I go back to Settings -> Media.

2nd time.

I didn’t even touch the settings and it INSTANTLY (after reboot) started again. All the way from the beginning. I figured to let it do it’s thing (again) and I started watching the task manager at the ‘home page’. It said my NAS’ CPU was at FULL CAPACITY and when I checked it was 50/50 Twonkey with another thing going on. Figured out Twonkey is a media server, so I’m assuming THAT is the setting it’s turning on. Nonetheless, this keeps building the database. I moved away from my PC & NAS so I wouldn’t interfere with the process.
I came back a while later and it was still busy. I let my NAS do it’s thing and started coding a little PHP, which shouldn’t interfere as I was only using few things on my PC.

After a couple of hours (talking about another 4/5 hours…) my NAS decided to hate me and again gives me the 500 - Internal Server Error mistake. Which brings my ‘story’ up to ‘now’, where I’m letting my NAS be as it is (as it’s still flickering) and haven’t rebooted it yet.

How can I even use this without the whole thing screwing up? I want to turn it on but apparently I’m not capable of doing that? How do I fix this? Anybody got an idea/a clue?

A fix for the 500 error has been promised. No word yet on when to expect the fix.

It could take days for the database to build up and device resources to go down to normal.

A restart would likely prolong the process, unfortunately.

I read about the error fix, I can live with that honestly, it doesn’t happen that much. Except right now, it happens.

Is there a way for me to bypass this error and have my NAS properly set up the media server?

I use my NAS daily thus it would be nice to have full access whilst my NAS does it’s job…
I assume it won’t help if I turn on share by share media serving?

I’m giving it another chance;

turned on DLNA this noon at around 1pm. It’s currently still running (it’s 9pm here atm) and it’s ‘stuck’ at the same screen… I’m hoping that this is either changing soon or that it’ll finish soon…

dammit.PNG

I don’t understand my NAS at some points though… I’m not even USING my NAS right now and yet this is happening;

This is my NAS’ CPU at 100%.

FYI - I see the same thing on my new EX2.  Anytime I enable the media server the cpu loading goes to 100%.  I thought I had fixed it by turning off FTP (This seemed to fix it at one point) but I have now seen it come back. 

Hopefully WD is going to provide a solution for this behaviour soon.

When enabling Media Server I fully understand that it needs to do it’s job of scanning and such. I turned it on again 2 days ago and it’s still going strong now. I’m wondering how long it takes for an average amount of data, because I can’t really use my NAS until it’s done else I’m pretty sure I’ll get the ‘500 error’ which is not really what I want to have right now.

The thing is that the screenshot in my last post was actually made without my Media Server being on and it was ‘convert’ which was causing this… I had no clue though what it actually was converting as it’s not really showing anything more info so I thought it might be a bug, but I don’t know…

An explanation from someone who knows about this would be nice tbh :slight_smile:

I’d love to at least understand what my NAS is doing half of the time or how long it’ll take to do it :stuck_out_tongue:

It might be busy for example, generating thumbnails out of the photos you copied over to the NAS.

Depending upon how much you moved over to NAS, it could take quite a while, even several days.

dashboard access has been known to crash during these times when only option is to pull the power plug, in turn causing the convert process to take even longer.

:frowning:

Was actually thinking about the same thing… Especially the ‘it could take days’ part.
It’s currently busy since 3 and a half days or something, still not calmed down and both my Twonkey + NAS are saying it’s updating the database.

In addition to this, I made this topic a few days ago :stuck_out_tongue:

http://community.wd.com/t5/WD-My-Cloud-EX4/Media-Server-updating/td-p/709610

Fun part is, with all the luck on my side I just took a look and my NAS now says;

Music Tracks:0      Pictures:0      Videos:0

While it’s been busy over 3 (and more) days of scanning/building/whatever…

Rescan/Rebuild didn’t do anything and when I look at my Twonkeypage it didn’t help me either… Great stuff :smiley:

I have 4615 videos, no Music and no pictures added. Im only using DLNA to stream Video to my PS3 and Samsung TV over CAT5. No problems at all. The DLNA database was sorted quickly. Maybe add each catagory seperatly??? See which file type is causing the delay? is it stuck on a corupted file???

Good Luck,

Adrian

I actually figured out it’s stuck on .m3u-files from my music, though I don’t want it to scan these… There’s no way to put in the rule NOT to scan the .m3u-files sadly enough… So… No DLNA for me I guess.

on mine, I disabled the media server entirely.

you could always just use PLEX media server on your computer that scans a particular folder on your nas and keeps

a database of media files.

From your comment you reccomend disabling the media server entirely. It seems that the commentor purchased the WD EX2 with the sole purpose of using it as a media server.  You then comment “In life, ther are 0s and 1s.”  Is it correct to take that comment as meaning that the WD EX2 is a “0.”

I have an EX4 and that one is a 0.

big fat 0.

I did give the person 2 options

1, disable

2, just change setting to skip photo search and search for music and video only.