Media server database internal server error 400162

hi folks

I have a 1 week old 3TB My Cloud which I’ve just finished very painfully backing up nearly 2TB of files from a 3TB My Book Live. 

I can connect OK and view all of the files on my PC but only a handful of thousands are accessible from my TV. When I try to rebuild or rescan the database I get the above error every time. I’ve rebooted a couple of times after getting the error message and then tried again but no joy.

Am I missing something? What else can/should I do or try?

Thanks for any assistance you can offer. 

Just to say that I have the same problem.

I have a 4TB WD MyCloud, accessed via an iMac, which I’ve been using for about 2 weeks now. Often all my media files appear to be duplicated so I need to rebuild the DLNA database. Whenever I do this the rebuild runs for a few seconds then I get the same error message as you. The file count then reads zero! The only way out of this is to reboot. After rebooting, the duplicate files have disappeared. I don’t have much stored on the drive at present: about 40 movies and 10 CDs, so it wouldn’t take long to scan the drive.

Have you also tried rescanning the content folders in “Settings / Advanced / Server Maintenance” via the Twonky Server interface rather than the WD MyCloud interface?

Hi sundazed

Thanks for your reply - I hadn’t tried Twonky, I’m a novice to all this kind of stuff but I’ll try now. Thanks for the tip!

I keep getting this error as well.

I tried to access the Twonky settings and came across a “Google Chrome cannot display this page” error…

Up until today I had no idea that the Twonky settings were on a different port, but I have no idea what I need to do to access it.  Would love some assistance if anyone knows what to do.

Edit:  Nevermind.  I manually reinstalled the firmware and it worked.

To access it replace the “/UI/” at the end of the address for the WDMyCloud web inteface with “:9000”.

So, if your web interface is at , enter instead. You get a bit more information there but in all honesty it doesn’t work any better!

Hi folks

Just to update anyone interested, this problem kept recurring so I’ve just done a System Only restore and the error hasn’t reoccurred at the usual point in a transfer. Also my connection to the drive seems to be much faster so so far all the better.

Oh good!

My drive hung in the middle of a reboot (flashing yellow light for 10 minutes). So I yanked the power cord out (paper clip reset didn’t do anything) even though it said not to. I reckoned it was my only option. Since then it’s been fine!

I am also getting this error when I hit the “Rebuild” button next to the DNLA Database entry. The only share enabled for media serving is the Public share and there are only a handful of images, so this should be trivial.

I just installed  V 03.04.01-230

I GET “Media server database internal server error. (400162)” when trying to rebuild DLNA db

I’ve rebooted my WD My Cloud several times already

These are the firmware updates I have perfomed in the past: 03.04.01-219, 03.03.02-165, 03.03.02-165, 03.01.04-139, 03.01.03-127 …

… and I had never gotten this error before. 

Should I go back and reinstall the older 03.04.01-219 ??



Rebooting your NAS will not solve this problem, but shutting it down, unpluging it and restarting it SOLVED mine.

Good Luck

Brand NEW 4TB My Cloud receives this error ‘Media server database internal server error. (400162)’. This is with the firmware update.

Rebuit to factory defaults and still receive this error attempting to scan/rebuild DNLA.

Why is there not a fix for this?

I also tried unplugging, rebooting, restarting, resetting everything I could.

This seems like it is more than just a generic error.


Media server database internal server error. (400162) here also.

Also I keep noticing when watching a movie, I suddenly just lose sound. This happens every day.

I’m starting if these all should be recalled and WD starts from scratch.

rgoodpa1 wrote:

Also I keep noticing when watching a movie, I suddenly just lose sound. This happens every day.

I’m starting if these all should be recalled and WD starts from scratch.

I don’t know how that would have anything to do with the Cloud – it’s just sending a file.  It’s not modifying the sound.

@rgoodpa1  I’d be very happy with a general recall.  Media server database internal server error 400162 is the last straw for me.  Ditching the case and recycling the HDD into something reliable.

I have the same problem. I have tried everything to no avail. It seemed to work fine with a few GBs of data and now that I have used more than half of it, it is not finishing the media scan… Any solutions?

Update: After having had enough, I tried installing miniDLNA which does what it is supposed to. No problems with the latest version which seems to be running fine. Someone has developed an automatic installer which makes things even simpler. :stuck_out_tongue:

Hi all,

The problem seems to come from the Twonky server and a solution was found by other members in the following topic:

I hope this will fix your problem as for me.

Best regards,

Eric Ersilio

I’m glad my thread was able to help you, but I’m still not clear how the Dashboard and Twonky interact…  I’m planning to do some experimentation to try to understand it.

I think it’s notable that many of the reports here are from new users, and this leads me to suspect that many of the problems reported here are caused by automatic firmware upgrades; I think I concluded that that was the main cause of the problems I had & documented in the thread you linked.

I think the answers to this firmware upgrade problem are:

i) stop media streaming

ii) do a system-only restore

iii) ensure media sharing is enabled on the Public share

iv) re-start media streaming.

For non-trivial cataloguing of your media collection (i.e. searching for music in Public/Music, etc.), you have to use the Twonky UI.  And, if you use the Dashboard to restart teh Twonky server, all your careful settings will be lost.

If I manage to bottom out the Dashboard/Twonky interaction, I’ll try to post a concise Guide thread.