Media player not reading external drive

i bought a wd media player recently and ive just used it twiice. and today wanted to watch a movie from my passport external drive 1tb. but when i hooked it up it didnt want to connect it kept saying coonecting to usb on top of the screen in yellow letter. so i thought i needed to upgrade the firmware so i did and nothing. i dont know whats wrong it was working perfectly just yesterday and now it doesnt want to read it does anyone know the problem ??? and the 1t drive is almost full but it was working fine yesterday so idk if that might be the problem.

no one ??

Welcome to the Community.

Did you try ejecting the hard drive or rebooting the media player? Have you been able to test if the hard drive works with your computer?

@Trancer yes i tried ejecting it but it doesnt even show up on the screen the external drive i mean. The hard drive does work on my macbook. It just says commexting to uub on top but never does ive also noticed that a minute upon connecting the drive the light blinking on the drive turns off i found it odd as it should do that… I stumbled upon saying that they bought a universal power cord could that be the problem but why if it was working before im confused on this situation…

I actually have the same problem.

It worked for the first 2 days I was using my WD TV. After that, it would not detect any of my drives. Even at the disk manager portion of the options. It just says in the begining “connecting to USB”. 

Has the thread starter solved his issue?

Hi im experiencing the same with my 5tb external element. i got it new to put my series collection and i tested with one complete series, few files, and it worked like a charm. added the full extent of the collection almost the full 5tb and its not reading, it just says at the begining “connecting to USB storage”.

I am trying to do a rollback of an earlier version firmware for my WD TV LIve I bought a little over a year ago because the most recent firmware doesn’t play all file types. 2.02.32 is what I have not and I have read a few other forums where after reverting back to 2.01.86 the files work again. When I plug in my usb thumb drive it just says  “reading USB” and then “Compiiing Media Library” but it doesn’t give me an option to synch or transfer content from the usb drive. 

follow my guide exactly

if it does’nt work, try a different USB thumbdrive