Media library still compiling after every re-boot

I have noticed that the last two firmware updates claim to have solved the problem that the media library re-compiles after every re-boot. However I am still having this problem, usually having to wait 5 to 8 minutes for the media library to compile every time I turn the unit on (other than from stand-by). Looking through the firmware issues threads I get the impression that others are not having this problem any more. Before I raise this as a firmware issue I just wanted to see if anyone out there can offer any solutions in case I am missing something obvious.

My media library is complied from a Synology NAS, connected as a network share via a wired Gigabit LAN. There are approx. 18,000 photos, 10,000 mp3 tracks and 2000 videos. I am on the new 1.08.17 firmware and have done a factory re-set. I have tried setting “auto-scan” to “during stand-by only” and also “once a month”, but it still re-complies every re-boot, even if no new files have been added to the NAS.

I have tried clearing my media library and deleting all the .wd files on my NAS. After this, the first compile takes about 20 minutes, and thereafter is back to 5-8 minutes each time.

All I want is to be able to turn on my media player and use the media library immediately, and to be able to restrict re-compiling to when there are any changes, i.e. when  new files are added. 

Any ideas?

 what revision do you have at the moment?

A new firmware was just released 

I am using the latest firmware 1.08.17, and my media player still re-compiles for 5 minutes every time I turn it on (from anything other than standby).

The last two firmware releases claim to have solved this problem. I cannot find any other comments on these threads suggesting that anyone is still having this problem, which makes me think I am missing something. So what I really want to know is:

1) Have other users found this problem solved, i.e. that they can use the media library as a source, but that it can be prevented from re-compiling other than when manually asked to do so (e.g. when new files have been added to the NAS) ?

  1. If yes, where is the setting to manage this? (note - I know how to manually re-scan - it is the prevention of the scan at start up that I cannot fathom - none of the “auto-scan” settings seem to have any effect)

Well, mine does it, too. 

WD’s comments in the release notes with this version are as much of a mystery as they were the last time they said that.

I have no idea what they think they fixed…

Sorry if this is a daft question, but are you sure it’s re-compiling?

What i mean is, does it say it’s re-compiling in a banner at the top of the screen, or are you just assuming it’s re-compiling because the light on the front of the player is flashing?

If it’s the former, then sorry I can’t help.

But if it’s the latter (light flashing, but no re-compiling banner) then I’d try going to network shares and switching them to ‘Off’.

Hope this helps (though it probably hasn’t).

Steve W

Pecker - Yes it is definitely re-compiling - there is the white banner at the top of the screen.

Tony - Thanks for the confirmation that I am not the only one having this problem. I will add it to the issue reporting threads so that WD are aware that the issue is not yet resolved.