Media Library never finishes compiling

Anyone else having issues with the media library never completing? I am using a synology NAS and all was fine prior to the latest firmware update.

Same problem, I don’t know why there is this problem.

have had same problems but when u restart the whole hub (cold reboot) it should be fixed.

(ein reboot macht immer gut)

I’ve tried a hard reset and countless soft resets - no joy either way. This is madening and ruins what would otherwise be a good product. Welll, that and the fact that it cannot “watch” network folders for changes and therefore has to have the device reset everytime to update the library…which never finishes compiling…

The Media Library compilation can fail if there is media that is “crashing” the compiler process.

You can troubleshoot this way.

Step 1> 

Connect via your PC and your network to map the Hub’s Internal Drive to a drive letter, say X:

Create a new folder called “.hidden.”

You will need to use the “DOS”  COMMAND LINE to do it:

c:\documents and settings\tony
c:\> x:
x:\> mkdir .hidden
x:\> exit

Now, open X: in Windows Explorer.   You will need to enable viewing of “Hidden files and folders”.

Step 2> 

Move ALL of your media into that hidden folder.

Reboot your hub.

Does the media library finish compiling?   (It SHOULD, because there’s not supposed to be any media now.)

Step 3> 

Now, move small amounts of your media OUT of the HIDDEN folder back to where it was bofore.

Reboot your hub.

If it COMPLETES compiling, go back to Step 3 and keep repeating.

If it does NOT complete, then you know that the issue is with one of the files you just moved.   

1 Like

Humm, now that we know how to hide a dir, can we create a hidden one and then put stuff in it and then unhide it at will? I’m thinking this would be a good way to keep some movies away from the kids…the whole security thing on the Hub just doesn’t thrill me much. There’s no way *I* know of to easily remove the secured folder from the setup option. But this might work for some of us.

Map your wdlivetvhub to z:

enter from start button search box in Windows by typing “command” then ENTER

type in z: ENTER

mkdir hidden ENTER

  >creates the directory named “hidden”

exit ENTER

Now go to the Hub and move files to the directory/folder “hidden”

Now go back into DOS and change to Z drive

enter the command > ren hidden .hidden ENTER

 >this renames the directory to “.hidden”

exit ENTER

Now go back and look for that directory/folder on the Hub! It’s Gone! but it’s still there…just HIDDEN!

To unhide it you just rename the folder in WINDOWS mode to “hidden” and it’s back again!

If there’s a simpler way to do this let us know but I’m glad I read this post!

I’ll give the hidden folder trick a shot, but all I have to say is that My Media Extender NEVER had (still doesn’t have) this problem with the current batch of files, nor does Windows 7 Media Center, nor does iTunes.

If any of the WDC folks are reading these threads, all I have to say is these types of issues are not endearing me to the product. Too bad I’ve already plunked the money down and have had nothing but goofy issues with every firmware update. I really shouldn’t have to reseort to tricks to get my product working correctly.

Bah Humbug

Yesterday mine spent a VERY long time compiling. I recalled having looked at a shared folder from my computer that has a USB drive attached that has about 47,000 mp3’s on it. What caught my attention was the light on that particular USB drive was indicating it was being accessed. So I tried to use Windowz to Safely Remove it but it couldn’t do it. Because I had logged onto it to look at it and because the Media Library is ON it started compiling all those files. I did manage to hit the setup button on the remote and turn off the media library. Then I cleared the login info for network shares under the network settings.

Cleared up my problem. I won’t try that trick again without turning off the media library first.

So you might want to check this out it may be what’s happening to you. Somewhere it’s found a large folder it’s trying to compile and maybe it appears to be hung because it’s taking so long to compile?

Did the hidden folders - no joy.

Moved content off the NAS and left only previously compiled files - no joy.

Hard reboot - no joy.

A great product marred by such a stupid problem…

Anyone have ideas? Time to consider a new product? Any eta on a decent firmware update?

I rolled back to 2.05.08 yesterday - problem solved! Yay!

I really hope WD soon changes the entire construct for how they handle the media library…