Media library lost track of all movies - twice

I have seen a bug crop up twice. I wonder if anyone else has seen it, and if so what you did to correct it.

I have two folders with movies, located at root of the shared WDTVLiveHub
Movies AVI  (with 85 .avi files)
Movies DVD  (with 59 .iso files)

For some unknown reason the hub suddenly quit showing ANY media in the two folders. The count was zero. Looking in the Files menu it also showed zero files. No movies could be found to be played.
Four movies that were in the queue were still listed in the Queue and could be played from there (proving that the actual files still existed).

All photos and music, located in other folders, were still counted properly.

I examined the two folders from a networked computer and see that all 144 files are still in those two folders. Powering the hub entirely off and on, and turning off the media library and back on in setup (forcing a update) didn’t fix the problem.

I renamed the folders (via the networked pc) to:

When the hub recompiled the media library it then recognized all 144 movies. But all media info metadata previously retrieved for several movies is lost.

A few days later the same exact scenario happened, for no apparent reason. I renamed the folders back to the original (without the underscore) and all is working again. Again all media info metadata for movies is lost.

The only clue I have is that both times it seemed to happen shortly after I copied rather large amounts of other media files (music, photos) into other folders…

I did not attempt to do the “Clear Media Library” option from the setup menus which is supposed to clear and rebuild the media library. I expect, but don’t know for sure, that this would have fixed it. Should it happen again I’ll try that option.

Any thoughts?

Hmmm.    The only thing that I question is that you said it only re-compiled the media library AFTER you renamed the file.

It should have recompiled after a power-off / power-on, without losing metadata.

Did you power off HARD, or just put it in Standby?

If it happens again, do a HARD power-down which will force a re-compile.

Oh I did hard power-down (and pulled the power plug too). In fact, before the rename, it would do the re-compile (blink the light, put up the info text), but the recompile just wouldn’t find those folders anymore. Instantly after the rename it did the recompile again but this time found the folders. I’ve learned not to bother getting media info on the movie files 'cause it is likely to be wasted effort. If this is a media library compiler bug it will show up for other folks too, soon enough.

I’m currently having the same problem wherein the media is visible via my computer, however the player is saying “There is no media in the current folder”. This happened first last evening when I was transferring files from my laptop to the Live Hub. I’ve done this many, many times without issue, but the player first said I only had 18 files when I know I had approximately 70. I don’t know what prompted me to remove the files back to the laptop, but for whatever reason, the player went back to the original 68 or so files. Tried again later without a hitch.

This morning I made newer folder icons and transferred it into one of two folders I have on my Live Hub. The Hub appeared to be fine; all folders in place, however the folder that I did not do anything to now said there wasn’t any media. I’m not freaking out too much as I can still see them, so I know they’re there, but I’d kinda like to see them on the TV?? Is there a solution out in the community? This was the first post I found, so I didn’t scour all the postings.

Thanks in advance.

I had a similar problem yesterday. I have two folders one for TV and one for Movies, when i turned on the hub last night all the files were mixed togather not showing any folders at all and even after recompiling the media library it stayed the same. I also checked it on my PC via networked drive and it shows all the folders and files in the correct place. Not really sure what the problem is.

try to rename your folders without

the avi and dvd word, and see if the problem persists.

if yes, contact wd support. They could provide assistance.

and how does the metadata dissapear? Does the xml files get deleted?

I may have found the reason for my same problem.  After deciding to create a whole new folder and transferring my video files into it, I noticed a couple of files that appeared out of place, one of them was a “Sample Videos” shortcut!  Somehow I must have inadvertently transferred this shortcut from the Videos folder from my laptop into the video folder on the Hub.  I’ve corrected the problem, and the Hub appears to be working fine again.  I’ll keep an eye on it to make sure it continues to operate properly, but I might suggest looking over your folders for any atypical files.