Media Library loses / doesn't show all items

I have the folder WDTVLiveHub\TV with a bunch of subfolders for TV shows. I save AVI files in those folders and after I watch them I delete them.

After I leave it either on, or on stand-by, for an undetermined amount of tine, some folders (with content in them) just stop showing up, or folders with recently added media don’t show up.

After a restart, it recompiles the media library, so while it’s doing that, I go into Folder View and can access the data, then sometimes when it’s done compiling, it works fine for a while, sometime it just shows a few folders.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

i have the same box and mine started messing up as well. sometimes it will fail to show a lot of my saved media files. for example, i deleted 1 old movie file lastnight that started with a “T”. when it was done deleting, it was gone but so was all my movie files that started with numbers into the movies that started with “B”. i turned the box off & on, even unplugged the power sourse numerous times, and still nothing. i put some of the missing movies on my flash drive and attempted to re-install them on the box. it completed syning in 2 seconds as if the files already existed on the box but, they still wont show up! does anyone know what to do? :angry:

I think I have a similar problem that I’m about to register with customer support.   I have my films stored in directories according to genre, I’ve just tried navigating to the ‘family’ folder to watch a film with my daughter and it’s only displaying films starting with S and later alphabetically… so no 'A’s, B’s, C’s  etc.

I’ve done a restart from the system menu and it’s compiled the media library again, but still going into that directory wont show any of the films beginning with a letter earlier in the alphabet than S.   They show up OK if I go to File View rather than Video View and navigate to the Family directory, and they also show up if I navigate from within Windows 7 (64 bit)  to the network share for the live tv hub player and USB drive that I keep them on.

As far as I remember they worked fine with the last firmware release, but I couldn’t swear I’ve had them working with the latest one as I don’t often watch the family category myself.