Media Library - Issues with series/film order

Firstly apologies if I’m asking this in the wrong section, but I wasn’t sure where to post.

I have a WDTV SMP using the Darklight theme by Tinwarble - connected to a QNAP NAS.  I’ve set up media library folders for video, music and photo’s fine and everything looks OK at first glance.  However when I go into TV series, all the episodes are out of order and this is also true for film orders also. As an example when viewing Mission Impossible films, The order it appears in is MI 1, Ghost Protocol, MI 2, MI 3.

When I turn off the media library and just use Network Share to view all my media, everything is in the right order.  Is there anyway to correct the issues I’m getting when using the media library function (or am i stuck using the network share option)?  As for now Id like to use the media library function as it makes it a little easier for the kids to navigate their way around.

Any help is appreciated. Thank you

Have you assigned Content Info to those movies?

If so, then something odd is happening, because they should be listed by their full names

Mission: Impossible

Mission: Impossible II

Mission: Impossible III

…etc, not odd abbreviations like you’re describing.

Unfortunatly Media Library view only gives the option to sort on the name of the video title from the content metadata. What you want (and me also) is the ability to sort on the actual file name.  Fo example I have all my James Bond movies in their own folder and named them in release order. e.g “JB01 - Dr No”, “JB02 - From Russia With Love”,… “JB15 - A View to a Kill” etc.  The problem with this is the Meta manager cant find the movie in the online data base because of the leading “JB**”. Tto get content so you must go to manual mode to fetch the data.  Once the correct movie data is found the title as determined by the data base is used by the name sort resulting in “a View to a Kill being the first listed”

Bottom line is it would be great to have an option to sort on file name not just title name.  This would be a great help for those of us that would like to name with the preceding article at the end and have the title sort logicaly. eg Adjustment Bureau,The or Adjustment Bureau_The.

Only way i’ve found to fix TV shows with the media library on is to use a program like this:

it adds leading 0’s to XML’s single numbered episodes so they appear in order.

As for movies I had the same problem with the Mission Impossible series so i used this:

And changed the XML to label them-Mission Impossible

                                                        Mission Impossible 2

                                                        Mission Impossible 3

                                                        Mission Impossible 4: Ghost Protocol

Thanks for that Draven, I’ll give them a try even though I’m not sure whether they’ll work with my thumbgen generated XML as I haven’t used the internal scrapper.

However I’ve been editing the xml generated by thumbgen using dreamweaver trying to solve the issue.

Basically, if I take my Mission Impossible films as an example.  I have called the original .mp4 files:

  • Mission Impossible 1
  • Mission Impossible 2
  • Mission Impossible 3
  • Mission Impossible 4

Now when I use thumgen to generate the movie sheet info it produces the following code to name the film:

Mission: Impossible
Mission: Impossible


I did try altering these but it didn’t seem to work.  So who knows, maybe it’s not this code I need to change to alter the order that these would be displayed while using media library.

I’ll just keep trialling and erroring till I find something that works.  It would be so nive if the media library had the option of ordering files by their actual filename or by the xml generated name.  It would make things so much easier.  Maybe we should start petitioning WD for this to be included in a future firmware update.

If I have any success I’ll let report back on here.

If you modify the XML AFTER it has been imported into the media library, changes won’t be included. You’ll need to clear the media library so it will be reimported.