Media Artwork


   I am using the My Media Library option on My WD TV Live.  I have a folder with TV shows.  Each show is in their own folder.  i.e.

Tv Show #1>Season 1>Tv Show #1s01e01


Now, some shows will display art on the main TV Show #1 folder and some don’t.  How can I fix this to get the artwork show up on the folder.


Create a jpg file of the picture you want displayed.  Call it “folder.jpg” without the quotes, and put it in the folder.  This is in the manual.

actually the folder.jpg thing does not work anymore.  You have to take a jpeg file, call it 0.jpeg (use the number 0 because it reads the first one in the folder).  Then rename it to 0.metathumb.  This should work.

have no issue with folder.jpg file… running firmware 1.15.10

I have no issue either.  It works for me too, also firmware 1.15.10

In regards to the ‘folder’ jpeg  - it will not work if you have metathumbs within that folder.  What happens is that the player looks for the first metathumb within the folder and displays that.  Yes, if you do have metathumbs in your folder you need to name a metathumb something like “0” to get it to display.

This has always been the case and has nothing to do with recent firmware updates.

Hope this helps.

I’ve had limited success with the “1.metathumb” approach. It may work for a while! but the SMP seems to eventually revert back to the alphabetically first “real” metathumb associated with a video. I am likely doing something wrong but can’t figure out what. I use a jpeg image and I name it “1.metathumb”, which seems to be the recommended approach. To be clear, the file is still a jpeg, correct? By this I mean the full file name is 1.metathumb.jpeg - I’m not actually converting the jpeg to a metathumb. This file name looks different than the metathumbs associated with videos, which don’t have any jpeg in the file extension. If there is a way to drop the jpeg extension then that is likely where I am going wrong - any suggestions appreciated.

Make sure your PC is displaying file extensions.

eg. in Winxp Tools > Folder Options > View > Hide extensions for known file types [make sure there is NO :heavy_check_mark: in the Box)

so now when you rename 1.jpg to 1.metathumb   Windows will display a Rename Warning

If you change a file name extension, the file may become unusable.


Are you sure you want to change it?

Click YES

Thank you very much – this seems to have done the trick!