MBWE white light single drive - editing files when drive extracted & connected via USB caddy?

Hi all,

So I made a mistake in editing my sshd_config whilst logged in over ssh and broke sshd. I’ve succeeded in extracting the drive and am using a USB caddy and fuse-ext2/MacFUSE in order to mount the drive under OS X 10.6.8. The drive contains four partitions:

  • disk1s1 - the root partition (2GB ext3 journalled)

  • disk1s2 - the data partition (~960GB unknown format)

  • disk1s3 - /var (~280MB - ext3 journalled)

  • disk1s4 - don’t know (1GB unknown format)

Here’s what I’ve been trying to do. I can mount the root partition read-write and edit /etc/sshd_config (in fact I saved a backup of it so I’m deleting the modified file and renaming the backup), but when I put the drive back into the MBWE and boot up, I find that ssh is still not operative (it’s still not listening on port 22 - my config modifications didn’t change the port).

Here’s where it gets weird. If I dismantle it all once more and plug the drive back into the USB caddy, the sshd config files in /etc have gone back to exactly how the were before the manual deletion and rename! It’s as though the drive has some sort of mirror backup that it automatically restores on bootup. I’ve tried editing other files and get the exact same behaviour - my edits just disappear!

So then, is anyone familiar with this problem or can suggest a way around it? I’m all out of ideas now. I am using MyBookClone from highlevelbits.free.fr but unfortunately the sshd config error was backed up to the backup drive before I realised the mistake. Also I don’t run Windows so cannot use his MyBookRescue software either.

I’m open to anything at this point - especially an explanation for this weird ‘backing out my changes’ behaviour.

Many thanks,


A little more info on when the file gets ‘reverted’.

I’ve tested editing a file whilst plugged in to my laptop via USB (I am ensuring it contains no resource fork and retains the correct ownership and permissions and modify date) then fitting the drive back to the MBWE board and plugging it into the mains. At this point it always powers itself up and there is disk activity for 10-20 seconds though I don’t press the power button.

Even if I let it only do that and then unplug it and return it to the USB caddy I find that the file has been reverted or (in some cases truncated to 0 bytes)!

Again, has anyone experienced similar or have any idea why it might be happening? Could it be something to do with ext3 journalling (I am issuing a ‘umount /Volumes/nas’ so it should be unmounting cleanly?), or can a WD employee tell me whether the firmware includes some sort of modification-check-and-revert?




The fuse-ext2 project page does state that read-write support is not bug free, and it seems I’ve stumbled over one such bug. The workaround I found was that, having plugged in the drive via USB and received the ‘this drive is unreadable Initialise/Ignore’ message, I needed to mount the drive read-write, unmount, then remount. All changes made during the second mount without unplugging were persistent, and not subject to the ‘reversion’ problem I was experiencing, which I’m blaming on fuse-ext2 faulty support for ext3 journalling.

Hope this helps someone else out down the line!