MBWE II (white light) won't open from Mac, won't reset

I have been using a 2TB My Book World Edition II (white light) network drive for more than a year. It is hardwired (CAT-6) to my router, as is my iMac (on which I also have a WinXP virtual computer running in Parallels). The drive has always appeared as a shared drive in Finder (Snow Leopard) and as a letter drive in My Computer in Windows. It also came up on my WinXP laptop and MacMini (Leopard). In all cases, I could simply click on the drive name and it would open, giving me access to create, move, edit, delete, etc.

Then, for no apparent reason, both Macs began asking for a username/password to connect to it. But no combination would work. Meanwhile, it has continued to work just fine with both Windows platforms.

I tried resetting it to the default “admin/admin” by pressing the reset button for 20 seconds, but it would not reset. I tried different “sticks” to press reset and also tried holding it longer. Didn’t matter - it won’t reset.

The good news is I can still access more than 700GB of files on the drive via Windows; the bad news is I’m trying to get away from Windows and make a full transition to Mac. Which I can’t do unless I can access that drive again from my iMac.

If anyone has any idea what has caused this - even better, how to fix it - or why the drive won’t reset, please share.



Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support