MBWE II (white light) won't connect to network

This hard drive has always been flaky at best and frankly has NEVER worked right. I didn’t pick it out - some IT consultants who maintain my server picked it. For years now, I’ve had to click on the drive button in Windows Explorer like 30 times before I can eventually connect to the drive. I’m was using the drive as storage on a network, but since this drive is so awful I just want to get access to it again and transfer my data off this drive. Unfortunately, I can no longer access the drive. The error message I’ve had to sit through in years of using this drive is 'Configuration information could not be read from the domain controller… " I keep clicking on the drive button, but now it’s not connecting at all. Also, when I was transferring data off the drive earlier today before it disconnected, the read speed was only like 200k/second. I’ve also tried connecting the drive directly to my computer via an ethernet cable and entering //myworldbook and can’t connect. All I want is to connect to this drive one more time so I can get my data off the drive. Then I plan to destroy this **bleep** product like that scene in the movie Office Space because I’m so fed up with this drive. I was going to buy one of WD’s recent cloud NAS drives for storage, but since this fiasco I’m probably going with a Synology NAS. I’ve read that WD’s NAS have the same speed and connection problems that this MDWE II is having. WD’s quality sure has gone downhill over the past decade if you ask me.

Dude, you ever tried the support team at WD? Maybe you have a bad drive that should have been replaced long ago.

I´ve had some problems with my unit once very much like the ones you are experiencing, I´t was a faulty firmware upgrade, eventhough I followed the steps carefully,  something might have gone wrong and never could get info from the device at a decent speed. I called tech support and they exchanged the unit. I have updated the firmware in my new unit. I can say the experience I´ve  had  with the Mybookworld II has been excellent. I encourage you to call support and see what can they do for you.

Carlos Alberto.

I have a MBWE II that I’ve had trouble connecting to for years now. When I last finally connected to the drive a few weeks ago, the drive’s speed was around a pathetic 100K. I’ve tried WD Discovery over and over to connect to the drive and it would never find the drive. I finally called WD tech support and the rep gave me suggestions for probably two hours to get the drive to connect but to no avail and finally said I was out of luck. He also WD wouldn’t send me a new drive because my drive was apparently out of warranty. However, WD also never issued a recall notice that this drive is **bleep** and I’ve put up with this drive not working for years. I’ve liked WD products in the past, but I’ve had three WD hard drives fail over the past two years. Someone in WD QC needs to be replaced if you ask me. The lack of a replacement drive offer doesn’t matter to me though as WD is a customer of my firm and, no offense, but  I’ll likely eventually charge them for the defective drive in a future invoice to them by jacking up the price. I’ve read hundreds of posts of people having problems with this drive - including lots of posts of being unable to connect to the drive. The outside IT consultants my firm has also couldn’t get the drive to work and simply said that it was a crappy WD drive with a history of failing after they too read all the reports of these drives not working. I didn’t give up though. As it might be useful to someone else, below is  how I got the drive to finally connect and run. Most of these steps are from various recommendations other users have provided and I thank them for their help. I really thought my drive was a brick, but now it’s working. These steps are for the Win OS.

  1. Enter the drive’s IP address in the Run dialog box (such as\xxx.xxx.x.xx.) I don’t know why this matters, but if you try entering the IP address using a browser the drive wouldn’t connect, but if you use the Run command box, the drive will connect. I’m not sure why using Run works and a browser doesn’t connect.

  2. If you can’t connect using the above Run command, ping the drive’s IP address (ping xxx.xxx.x.xx). Keep pinging the IP address until you get a reply. In my case, the drive sometimes takes between 5 minutes to 2 hours to finally reply to a ping. I just kept trying and eventually the drive awakens. Then use the Run command procedure. This step allowed me access to the drive, but both WD Discovery and drive mapping still couldn’t find the drive.

  3. Once the drive ‘awakens’ or otherwise has some sort of communication (ping reply), enter the same IP address in a browser and then login (as shown on page 83 of the manual). Although I could login to the drive, it was painfully slow. Like watching paint dry. If the browser won’t load, keep refreshing the IP address once every 15 seconds. If you hit the refresh too often the drive will have too many connections and will disconnect. 

  4. Once logged in, a message showed up that my volume was in degraded mode - which is apparently why the drive was very, very slow. To check if this is the same case for you, click on Advanced Mode, then Storage and then Disk Manager. In my case it took a couple of minutes for the drive to process any request though.  Both of my hard drives were listed as Good, but one of them had a little icon to the right for Clean Disk option (meaning the drive was having issues). This drive was apparently affected somehow. I was still using the drive’s default Raid 1 (mirroring) setting and the DataVolume was still intact. I clicked on the affected drive and after 20 seconds the drive was clean and the MBWE’s speed increased significantly. No more clicking on an option and having to wait minutes for the drive to respond. I don’t know what happens though if your DataVolume is affected and if clicking on Clean Disk wipes your drive or just cleans/repairs it. In my case only the mirror drive was affected. I suggest calling WD support if your DataVolume drive is the affected drive.

  5. Now that the speed was back to normal, I used WD Discovery which now found the drive. I then mapped the MBWE II’s drives using the Map Network Drive to remap the drive.

  6. Another suggestion that I took (though I don’t know if it did anything useful) was to change the MBWE II’s time (NTP) server to match the server’s time server. Some posts have suggested that if a server/computer has a different time server from the MBWE II’s time server, the different time stamps can cause connection problems due to synchronizing issues. To change the time server, switch back to Basic Mode and select the Date/Time icon. Then replace any time server shown with the same time server your server/computer is using. Since my server uses the government’s time server, I changed the MBWE’s drive from pool.ntp.org to the nist service my server uses.

Maybe this post will help someone else avoid the hours I’ve spent trying to get a MBWE II drive to connect. Or maybe it will give WD tech support some useful steps to help others. I’m just happy that the drive now works (at least for today).