MBWE and jumbo frames

Just found something funny:

Looks like My Book World don’t even fully support standart size MTU not talking about big size Jumbo frames like 9K.


According to comment in following article - http://www.maximumpc.com/article/howtos/how_enable_jumbo_frames you can test Jumbo frames with this command:

ping -f -l <mtu size> <ip of lan machine with most hops from the one you're pinging on>

So I entered  ping -f -l 1500 MyBookIP and got that message "“Packet needs to be fragmented but DF set.” suggesting that value I entered is not supported.

Also I tested various size Jumbo frames with My Book World and found that setting it higher than 1500 actually slowed down transfer speeds. (when testing, of course I set same value in other devices in my LAN, so that should not be a problem).

I get the same result.  The magic number for me is 1272 (which, when combined with the TCP overhead, is 1300).

The strange thing is that ALL of the computers on my network display this behavior when pinging each other.  I tried all combos (computer to computer, computer to NAS), both through the fast ethernet switch on my wireless router (a Linksys WRT54G) and bypassing the router through my Netgear gigabit switch.

Plus I tried DSLreports’ tweak tool and it told me the same thing–that I’m only getting 1300 (it actually suggested that I “raise my MTU to 1500” so, from their end, mine appears to be manually dialed back 1300).

If you google “MTU 1300,” you’ll see that lots of people have this issue.  If I figure it out the solution, I’ll post the info here.  Please do the same.