MBW II accessible from Parallels WinXP virtual computer, but not from iMac hosting it

My MBW II (white light) is connected to my router as a network drive. And until a few days ago, I could access it from any computer on the network, including both my iMac (Snow Leopard) and a WinXP virtual computer running in Parallels on the iMac.

Now, it’s still accessible from the virtual computer, but when I try to reach it from the iMac, I get a username/password demand, which it never did before. I’ve tried every username/password combo I’ve ever used with WD and nothing cracks it. As the iMac is my primary computer, this is a major problem.

Anybody know how to tell the iMac I don’t need a username/password to access the drive - or how to find/set same if I have to?


Hi there.

When exactly is the drive asking for a username and a password? What if you try to map it as a guest rather than a registered user?

Tried the Guest approach, but it never manages to connect.

As to what is being asked, when I open Finder on the iMac, it shows the drive under “shared devices” on the network. But when I try to open it, a message pops up asking me to connect as a Guest or as a Registered User, with blanks for Name and Password if the latter. If  I click on Guest, the activity icon in the bottom right corner of the Finder window starts spinning madly, but never connects. I once left it spinning overnight and nothing had changed by the next morning.

If I try entering a username/password to access as a Registered User, I get an error message saying:

     “You entered an invalid username or password. Please try again.”

I’ve tried every possible log-in combination, starting with what I use to access my WD account online and including the default combo. Nothing works.

All of which is even stranger when you consider I have no trouble connecting to the MBW drive from the WinXP virtual computer running in Parallels on the same iMac, using the same hardware connections, but its own version of Network Magic to access my LAN.