MBLD & WD TV Live Hub

Hey everyone,

I hope someone is able to help me with a few Issues. Most of the posts I’ve read are a few months already out of date.

I have a 6TB MBLD which I bought in June, a 1TB WD TV Live Hub which I’ve had for a few years now (but recently bought a wifi toggle for it), a PS3 Slim model and I’m using a Macbook (2008) running OSX Snow Leopard and VUZE to stream anything recent until its transfered to the MBLD.

Everything is completely up-to-date

So it’s now August and I read that WD was supposed to have solved the MBLD-PS3 problem by now.

Every now and then, I can see the MBLD on the PS3 as a media server, but it’s never there for very long. and once it’s gone, it can be weeks before I can see it again.

Another issue that recently arose, when i was streaming from VUZE the other night to the WD TV Live Hub on my wifi, and while watching the show, every 5 minutes or so, it would stop and a message saying " you have been disconnected from the media server" pops up. Now i recheck the wifi connection each time and start all over to no advance.

I also use the WD2go app on my iPad and iPhone. It would be great for it to support .avi files like so many other apps out there do. And if not, to atleast be able to open the files with another app (which I’ve read you could but I can’t find an app to do it with)

I have been using WD products for many years now. I have :

WD TV Media Player

WD TV Live Media Player

WD TV Live Hub Media Player (ive bought 5 others and sold them to friends and family as well)

1 - 1TB My Book HD

2 - 2TB My Book HD
2 - 3TB My Book HD

3 - 1TB Passport HD

1 - 6TB MBLD

So as you can see i’ve got a small fortune in WD products lol.

I would love for these issues to be solved soon. It would make my home set-up a lot easier.

Thanks for the help,


For the PS3, does the same problem happens if you use a wireless or wired connection? On your ipa/iphone you need to download the app that will allow you to play .avi files, the wd2go is unable to play any type of video.