MBLD Connection Issues in Windows 7 (Connection to shares drops)

I’ve referred to this issue a few times, but (since I am rarely onsite with thus device), here it is again in some more detail:

My friend runs a MBLD with the latest FW (updated 2 days ago) on four networked Win7 PCs via a Thomson cable modem/router and a switch (2 PCs per switch, due to the office layout). The four shares are properly set up and users assigned. Win7 on all PCs, however, holds the connection to the mapped shares for somewhere between 5 minutes and a few hours, then drops the connection for all PCs all of a sudden, saying the the network name is “already in use” (free translation as the PCs are set up in German). Nothing (that I’ve found) can restore access to the shares … except a reboot of the MBLD!

MBLD seems to be dropping Internet connection every now and then, but oddly not when PCs can’t access it. There’s a mix of wired and wireless going on, as some one switch and 2 of the PCs are connected via Wifi, rather than Ethernet.

All four PCs have McAfee"Total Protection" running, but I doubt whether this could be the problem. I’ve checked the cablemodem’s settings and have found nothing obvious.

I’m fairly desperate at ths point, as my friend runs a business and needs access to her files. Any and all suggestions are welcome!! Many thanks.

I would try pulling the MBLD off of the Thompson and hooking it up to the other switch to rule out the modem/router as the problem.

Thanks … and should’ve said: already tried that. The current config is as follows:

  1. cable modem / router / access point

1,1 Ethernet to Switch 1

1.1.1 Switch 1 to 2 PCs (one via Ethernet, the other via Wifi directly to 1.) and MBLD (obviously Etherne)

1.2 Wifi to Airport Express (AEX)

1.2.1 AEX to Switch 2

1.2.2. 2 PCs via Ethernet to Switch 2 

All PCs are in the same Windows workgroup and can see/access each other — but not the MBLD when the connection has conked out.

The wird thing is that there’s no saying when the connection to the MBLD’s shares will cut off (after restarting MBLD) … it just quits.

Have you tried setting a static ip in the MBLD dashboard and reserving the ip using dhcp reservation on the router to see if that clears up the issue?

No, I haven’t tried that, but then the IP hasn’t changed since I first installed the MBLD about six months ago. The whole issue came about then my friend’s business moved three weeks ago (same building, different floor). Using the exact same equipment as before…

Things that make you go hmmm…

TonyPH12345 may have some things you can try if he catches this thread. Hang in there…