MBL2 disconnecting from the network


I’ve recently connected a MBL2 to my home network, and am having trouble keeping it connected.

It’s connected by ethernet to my Airport Basestation Extreme, and I access it from my Windows 7 laptop wirelessly.

If I’m not accessing the MBL2 it sits happily connected to the network.  However, after about 5 mins of use - writing and reading - wirelessly it will disconnect.  The wireless network logo in the task bar gets an ! mark though I can still access internet.  If I open up explorer, the Z: in my networks will have a red X against it.

Disconnecting my computer from the network and reconnect reestablishes the link (! and red X go away) and I can access the MBL2 again.

Can someone help me solve this problem?



Are you letting the MBLD get it’s IP by DHCP?

Interesting enough there is someone else on this forum who is having similar problems with the MBLD disappearing. Just for this other member the MBLD disspears more-or-less immediatly.

Is the router’s firmware up-to-date.  If you can, borrow another router that’s not fron the Apple stable and see if it makes a difference.


Yes I’m letting the IP be set (I.e. not fixed). The firmware on the MBLD and apple extreme are both up to date. It’ll be difficult to lay my hands on another router. Happy to try mucking around with settings at home if there are any suggestions.


A hunch. Try different wireless channels on the router.  Use http://www.nirsoft.net/utils/wireless_network_view.html to discover what routers are in range and what channels thry are using. I had a wireless performance issue and stuck my router on channel 4. Usually routers will try sit on channel 1, 6 or 11 to try avoid interference but then they have to deal with all having to share the same frequency.

Worth a try.  I use an MBLD wireless and wired and it just works. The router is a Linksys E2000 router. The router is now a little dated but selected because of it’s reviews and that it offers the best throughput, at the time.

You could try a different network cable between the router and the router?  I know this bit seems odd, but I have had times where a hard disc seemed to be failing and the solution was to changes the SATA data cable. Why would a SATA data cable fail? Don’t have the slightest clue.

So I ran it, and the 2.4khz channel is on 6, the 5khz channel is on 149.

There are two other signals in range running on 1 and 6.

Set your router to operate on an unused channel not too close to one what’s used. for the 2.4Ghz select channel 11.  For the 5Ghz channel try some other channel.  Thing is, there may be other equipment using the same frequency range, like a cordless phone which I think is one device that operates in the 2.4Ghz range.

Experiment a little.  This may or may not be the issue, but it will eliminate or prove if it is radio interference.

The network settings seem to have been the problem.

I set the 2.4 khz to channel 5, which is not used in my area.

The Airport extreme also lets you establish a 2.4 and 5 khz network separately, it’s in the advanced wifi settings.

I now have my computer attached the 5 khz network, and everything else (ipod, ipad) attached to the 2.4 network that overlaps with others in the area (though on different channels).

I’ve been playing music of the NAS continuously for a few hours without disconnection, so hopefully that solves it long-term.

Thanks for the help.

Please consider NOT using channel 5…  

In 2.4 GHz, there are only THREE non-overlapping channels – 1, 6, 11.

So by using 5, you’re effectively stepping on channels 1 and 6 as well.


Not sure I really understand the response, though happy to select anything that makes the whole shebang work better.  Are you saying I should only select 1,6 or 11, or that I should choose something that’s not close to any of them?



You should only select 1, 6 or 11 if at all possible.

Ok.  I’d be interested to know a little bit about the ‘why’ only use 1, 6 and 11.

Also, the Apple Extreme comes with the 5khz defaulted to 149, should that be on one of 1, 6 or 11 too?

Had a hunch it woiuld be either router firmware or wireless signal interference.  Glad it’s been sorted.  :smiley:

Me too!  I’m relying on it for my music collection, so drop outs would every 10 mins would have been impossible to live with.

Yeah, I know how this works and the reason for using 1, 6 or 11.  I’ve got a smal wireless issue at my end and after seeing what about my area I settled for channel 4 which in one go cuired my own wireless connectivity issue.

There is a reason why more than just those three channels can be selected.  As I mentioned before there may be other reuipment in the are using that part of the 2.4Ghz frequency so using a channel which is not 1, 6 or 11 may be the only option.  If that’s the case then that’s what it’s got to be.  I my case channel 4 is working absolutly fine for months.

TonyPh12345 wrote:

You should only select 1, 6 or 11 if at all possible.


Just the way it works.  I use channel 4 on my router and a small amout of my signal will bleed over onto channels 1 and 6. Anything on channel 1 will not bleed into channel 6.  Channel 6 won’t bleed into 1 and 11 and so on…

I nhave no data throughput issues with my router on channel 4. Always works on full speed and a good signal to noise ratio.

Dropped out every 10 mnutes? Seems somewhere round your spot there is some sort of becon or some equipment that brodcasts the channel you has issues with and it’s signal is far stronger than the router’s, henc the drop-out.

Channels 1, 6 and 11 are preferred. My advise is use what works for you. In this case another wireless router would have had the same issues.  :smiley:

jb2626 wrote:

Ok.  I’d be interested to know a little bit about the ‘why’ only use 1, 6 and 11.


Also, the Apple Extreme comes with the 5khz defaulted to 149, should that be on one of 1, 6 or 11 too?


I thought this had solved my problem, but it’s only improved it as I still experience drop outs when writing to the NAS but reading is generally ok - I am able to play music without problem (not streamed, I have DHCP and itunes streaming disabled) but rather just accessed by my media player.

I’ve split the airport extreme to run the seperate 5khz (channel 149) and 2.4khz (channel 6) networks.

I’ve connected my laptop to to the 5khz network, the ipad, appletv & 2 iphones to the 2.4khz.  The only thing connected wireless network is the laptop.

When I’m reading from the NAS it’s generally ok, but when I start writing to it I have problems.  My computer losses connection to the NAS and the internet (the warning sign is a ! on the wireless icon).  If I’m not writing to the NAS the computer will stay connected without problem.  Reconnecting to the wireless network solves the problem without rebooting but this is obviouly not ideal.

I’ve tried swapping the laptop connection between the 5 and 2.4 networks and the problem persists.

The NAS and airport extreme have the latest firmware on them.

Any ideas?

What you are describing is making he NAS seem to be less of the culprit and seems to be pointing more and more to the router or other device(s) trying to do the writing.

A Guesstimate…  Ethernet networks usually use a default MTU of 1500.  Try an MTU of 1420.  I’m not sure about the AirPort router but the one I have allows the MTU to be set to a different value.

Maybe try a lower MTU setting on the computer first before messing with MTU settings on the router.



I’ve changed the MTU on the computer (can’t change router settings), but without an improvement to the situation.

A diagnostic/troubleshooting step.  Connect your computer to your router using a wire and disable the wireless adapter on your computer and let us know what happens.


I previously had the MBL2 connected by ethernet to the computer (and not connected to the router).  At that time, the MBL2 worked fine with the computer allowing me to do the initial data transfer of my music & backup without dropping out (and it was fast).  When the MBL2 wasn’t connected to the router I never experienced getting disconnected from the router previously.