MBL - Very slow transfer?

Hi all,

I have just brought a new MBL, to use as a backup and to store my iPhoto library.

Here is my problem:  I have been trying to copy my iPhoto library from my MacBook Pro across to the MBL but the estimated time keeps giving my between 3 and 4 days!  The folder is only 85Gb…

I have tried both wireless and conneced directly to the MBL, both with no difference…

I am at my wits end now as I was really excited about getting this device but now I am just very frustrated  :angry:

If you have any tips I would be really greatful for the help…

Thanks in advance.


You may try transferring files of a different type, and in a small quantity, to see what transfer speed you receive. You may also try from a different computer, with a direct cable connection, in order to compare results.

Thanks Vadir.  Small files seem to transfer quite quickly.  It has just finished backing up via TimeMachine and it took about 24 hours (150Gb).

I don’t have another computer to compare with and when I connected directly to the WD device it seemed to make little difference.

Where can I see the transfer rate?

Thanks in advance,



to know the download rate, try Istat menus


I have a mac and the download rate can vary a lot : from 20 ko/s to 5 Mo/s. I’m using it with iTunes.

I’ve been where you are Noodle.  When transferring from my Mac to MBL I got the same multi day transfer rate scare.  But it actually got my gynormous iPhoto file moved over in a couple of hours (about 57 gb).  I’m willing to be patient loading MBL from my Mac (by the way, I’ve configured my MBL as a RAID array), but my frustration is with the transfer rate back from MBL to my Mac.  When I fire up iPhoto, it takes a frustratingly long time to load my photo library.  Similarly, when I try to navigate around in iPhoto I spend much too much time staring at that little multicolor pinwheel as I wait for photos to load.

I am on my second MBL.  After seeking WD phone support to try to improve the transfer speed I was advised by the help guy that he thought my drive was defective so returned it for another.  Unfortunately that doesn’t seem to have done the trick.  In my first go-around, I also moved my iTunes library to MBL and found songs playing back with hiccups, indicating the data transfer was not flowing smoothly. 

Here’s what I’ve done so far:

Bought a gigabit switch and now my MBL and Mac are both plugged directly into it using CAT 5e cables.  I am not even close to being a network expert, but my understanding is that my U-verse router (which is not gigabit) and is also plugged into the gigabit switch is only being used to access the Internet.  I am assuming it is not the source of the consipated transfer rate.  Could I be wrong about this?  Are there settings I need to make in my router?  Does anyone have any suggestions.  I just don’t think this is working as designed and if I can’t fix the transfer rate, I’m going to need to return this second MBL to Best Buy before my 30-day return option expires.  Any help would be appreciated.  Thanks.


I’m not a nbetwork expert, but as I understand it in a switch any device in the network should be able to use the full bandwidth of the switch without the data going through server.  The server (the machine with the DHCP server to be more precise) is only used in this capacity to dish out IP addresses, if not manually assigned. 

I’m also in a similar situation with ridiculously slow transfer speeds.  I’m getting about 1MBps wirelessly and about 3MBps when plugged directly into the router.  Its just doesn’t make sense.  If I could get rid of the NAS, I would, but it’s being used with a ATV2 that needs a NAS SAMBA share/drive instead of a going thru iTunes.  I wish I hadn’t invested in this setup, but at leaqst its better than the Seagate that didn’t even support SAMBA.  But I’m only uploading files in the background so it really doesn’t matter if it takes all night to complete for me. 

Check the ethernet adaptor on your computer and see if there is an option labelled something like “Jumbo frames” or “Jumbo packet”. If it’s on, turn it off and try again.  If it gives you options then set it to 1514 bytes. Might work. Worth a try.

Thanks Myron.

I found an adjustment in the System Preferences, Network settings.  Therein, I max’d out MTU (whatever that is) to Jumbo (which sets MTU to 9000 – up from 1500 Standard).  It did not seem to have a meaningful impact.  Also, I noticed that my Mac had both ethernet and wi-fi turned on.  I turned wi-fi off, thinking the machine may be trying to execute transfers via it rather than the ethernet cable.  Alas, that had no impact either.  I did reboot after making these adjustments thinking that may help, but it did not.  Still stuck at a much slower transfer rate than I can’t help but believe is designed into the hardware.  Shouldn’t the transfer rates between the networked My Book Live Duo be the same as that from the hard drive in the Mac?

Here is another question.  Do I need to “index” my photos manually to make them speak more fluently with iPhoto?  If so, how in the world do you do that?  Thanks for any help folks.

Also, I’m set to “full duplex, flow control” rather than simply “full duplex.”  Does one or the other make for faster transfer speeds?  Does this matter?

What’s the make and model of your router?

As to the MTU?  I got all mine set to standard settings and values and everything works very quickly.

I wonder if there is something on your network or computer that is setting the dont-fragment bit on TCP packets.  What if you se the MTU to 1420 below?  Any difference in speed if you do that?

Thanks again Myron,

My router is the standard AT&T Uverse router.  It is not giabit, which is why I installed the gigabit switch.  Unfortunately, changing the MTU to 1420 did not do the trick.  No change in performance.  A friend of mine set a Tivo unit up in his network and to make it work properly had to change some settings on his router despite the fact that he was using a gigabit switch.  That’s why I’m wondering whether there’s some magic in the router that is constipating the system.  Again, out of my league.

I’m thinking of returning this unit and trying a Seagate Black Armor 4T drive.  It’s more expensive.  I wonder if this is a you get the performance you pay for situation.  But I just can’t imagine anyone would find the performance I’m getting from the MBL for viewing photos acceptable.  Dang.

Try a simpler down to basics solution.  What if there is something wrong with an RJ-45 socket or one of the network cables?  All four pairs of wires on the Car5e or Cat6 cables need to be connected.  It is possible that there is a bad connection but the two pairs that are needed for a 100Mbit connection are working. Investigate the problem from that angle.

Many forget that it could be a simple connection fault and mess about with the settings.

If there is an open circuit on the network wiring then no amount of tweaking will speed things up.

Also remember that it could be the ISP issue if the speed issue if from a connection from the Internet into your home network.  Check that out too.

I am coming to the conclusion that perhaps the CPU in the MBL is simply not fast enough to do what I’m asking it to do.  My iPhoto library is about 59 Gbs.  A pretty chunky file by any standard.  When I fire up iPhoto, it takes at least a minute to populate the thumbnails on iPhoto.  Even after waiting a long, long time for iPhoto to get populated by the NAS, navigation is unacceptably slow – with that little colored pinwheel showing up constantly.  I’m thinking that all the back and forthing from computer to the NAS required for me to work with the many photos on in my library is simply overwhelming the drive.  The MBL has a CPU processor speed of 800 MHz.  The Synology Slim, at the other end of the spectrum for example, has a CPU with a speed of 1.6 GHz.  I’m thinking that may be my answer: more horsepower is needed under the hood.  Any thoughts from my fellow electronics grease monkeys?

I had experienced the same frustrating problem with the ethernet MBL.  I have a late 2011 iMac, Lion 10.7 with an airport extreme.  I wanted my MBL as a network drive and it was working very well (servicing another iMac, two iPads and an iPod Touch).  The only glitch was the extreme lag when using iPhoto.  My data files were fine, my iTunes were fine but the iPhoto displayed the same symptons that you observed (extremely slow).

In the digging I did on other forums revealed it is not an issue with WD drives exclusively, but to most drives that are not formatted to the mac formatting.  To test this, I used my LaCie drive formatted for mac, copied my iPhoto over and tried it.  The results were a lightning fast iPhoto - the way it was supposed to run.

I do not believe I can format the ethernet edition of the MBL HD.  I’m very disappointed that I cannot do what I want to do with the MBL.  Too much time has elapsed for a return.  Anyone else come to this conclusion?

The problem is probably Apple wants everyone to do things the Apple way, without any deviation; kinda like one cannot change the 7 point system font size even since back to 2004 as I’ve read; lowering a monitor’s resolution is NOT the good answer.  I’ve got the 2nd half 2012 mac mini that is just about useless for anything but a door stop.

The MBL does have sufficient horsepower at least under win7 wired.  Yesterday, I transferred about 4.7 gigs of audio consisting about 450 files in about 33 MBs; then did the same for 3 DVDs ripped (about 8.7 gig) in around a very surprising 57 MBs, probably due to the long small number of files.

The xfer was from the MBL to a switch to the router to my computer to the external usb3 hard drive.  The computer’s cpu is a intel e6550 & built around 2005 or so; does have 8 gig memory now tho.

I do notice that sometimes I get “only” around 12 MBs for audio xfer (backup) when the number of files/bytes are small as in around 1-2 gig.  I do use ms’s free richcopy which does just file copies & the default is using 3 threads to copy so that more than 3 files can be copied “at the same time”; not a fancy backup.

Erm…  Over a networ link it does not matter how the network storage drive is formatted.  The operating system of the client computer does not know the format of disc on the network storage device.  It just knows there is a resource there that it can access.

Yes, true statement from the operating system perspective.  iPhoto is proving to be a different animal.  The resident apple experts on other boards have all suggested that external drives servicing iPhoto will need to be formatted to mac format or it will perform sub-optimally.  My observations fall in line with their recommendations.  iTunes and the normal file transfer activities work fine over the network regardless of formatting.