MBL Suddenly decides to stop working

Hi everyone!

This morning I got a message from MBL saying that there was a CID DB Error, and after searching through the forums here I went to go update my firmware. Before I even got the chance to unzip the file, the MBL just disapears from my Mac. Can’t find it even with the CD. 

Phoned up WD and they told me to factory reset the MBL using a Windows PC because there was a ‘Mac database issue’ I’m all game for doing this and seeing how it works out, but my Windows PC is connected to my network through ethernet, as it can’t get wireless for some reason? How can I attach the MBL to the Windows so that it is recognized? Can I do it through ethernet cables?

Any help you could send my way would be excellent, only had the MBL for a month and it’s been running smoothly up until now. 


After spending 40 minutes on the phone with an advisor I’m still confused. I went through my router settings and tried to get an IP address for the MBL, through both the PC and the Mac, there was no address to be found in my router settings. The guy told me to ensure that UPnP was turned on (it was) and if not I should connect my ISP!? Why!? When it has worked perfectly before, and after being told that the MBL was connected. 

With both the Windows PC and my book connected to the same router, you can use WDlink to find the MBL, if that doesn’t work press the reset button on the back of the MBL for 4 seconds and try again, you can also try connecting the my book directly to the computer and it will also work.