MBL slows down internet connection

Hi all,

Purchased an MBL last week, but whenever I connect it to my LAN, it slows down the external internet connection.

Internet connection is fast one minute, then slow (to a crawl) the next.

I’m on Virgin XL, so have plenty of bandwidth.

Any ideas as to why this might be?

I think I have the same problem going on. I’ve been using the drive for about a month now. What I noticed more than the slow internet was whenever I tried to stream video, the video would pause every second and not restart again until I clicked play again. I fiddled with Windows for awhile trying to fix this. My wife told me that ever since we hooked up the drive she noticed a slow internet. So last night I powered down the drive.

After that I noticed the video problem has gone away, and the internet seems much faster. 

For now I’m going to leave it off. It’s a shame because it kind of defeats the purpose of setting up

automatic back ups. 

The same here. We’ve had to disconnect it as well for now.

I tried setting a static IP address which I think made a bit of a difference but it’s just as bad really.

The remote access is on and off as well. It’s as though it’s accessing the net at really high data rates.

The KB is useless.

WAG160N Broadband Router with MBL in Ethernet 1

Ethernet 2 goes of tow a WRT54G router connected to a Samsung Smart TV and XBOX

Ethernet 3 goes off to a laptop.

WiFi set up with a mix of ipods, laptops, wii, and desktops.

An update on what I have found. After the WD MBL appeared to settle down and work well with good access across the LAN and REMOTE I did some editing and it all went bad again. I had mapped the drive on to a laptop connected via ethernet to the same router as the MBL. I was cropping pictures to view in 16:9. I did about 100 before stopping. Some time after we noticed the WiFi on the router had gone down and wasn’t connecting properly. A few reboots later and still no good. I then tried leaving the MBL powered but disconnected from the router. This time the router reset and everything was fine. I left the MBL to do whatever it does and about 12 hours later plugged it back in and it’s all okay. It’s almost as if the MBL is processing the revised data files and during that process it is taking the network down by doing something to the ethernet which is then causing my router to stop accessing the net and wifi properly. So it now looks like everytime I edit and possibly copy anything to the MBL I have to disconnect it for a number of hours before being able to access it.

If I find any further information I’ll keep this post updated.


I spent 1 1/2 Hours on the phone with WD support today trying to resolve this issue. In my case it all came down to the formware of the router. It was xxx09 but WD found a xxx16 version. It wasn’t entirely certain if that firmware was for my exact model of router. (Annex A) but it did the job. This time instead of the progress bar on 100MB of pictures just hanging after around 60MB this time it completed the job. There was a moment where I thought it had hung up but then it continued. I reckon it was something along the lines of version 9 couldn’t handle the data flow whereas version 16 could.

So I suggest you upgrade to th elatest version (as recommended) although you may have to trust the version it lists.

So for now it’s all great. Nothing wrong with the WD MBL.

I would commend their technical help who were useful and helpful.

I’m glad to hear you’ve got a solution that is working. In my case though it’s not the router. I am convinced that this product is not usable for my needs. The firmware on my router is up to date. I’ve even tried connecting the drive to another router that I have, tried both routers with one of them set in bridge mode with the MBL on it…nothing works.

What I’ve found is that if the drive is plugged in to my network it interferes with the conection esp video playback even when the files are stored locally on the PC that is trying to play back. The only way to resolve it is to power down the MBL then re-boot the PC.

I’ve turned everything off on the drive ( Twonky, ITunes etc…) as I only wish to use this drive as a central back up

for our computers. I’ve reset, both quick and full factory restore, and have decided that the hours I have spent trying to make this work are just not worth it.

I am going to try and return it, and am going to use an old P4 3.0 extreme edition with a set of W/D SATA Rapturs set up in a raid configuration as a file server for storage. If they don’t take it back it’s going into the trash. My time is valuable and this product has consumed enough of my time.

Drive is going back…bought a Seagate NAS220. WIsh I had done that from the start…

After a few days of acceptable operation the drive is so unreliable. It takes the network down all the time. Generally when transferring more than around 50MB of data. It may well be the router WAG160N which has it’s own issues according to forums but it’s only ever the MBL that takes causes the network to drop out.

There are enough posts on these forums to go along with the best suggestion I’ve heard so far which is to go out and buy anything other than WD!

Yes I have the latest drivers and firmware.

Yes the router has the latest drivers and firmware.

No there aren’t any IP conflicts.

Although set to a static address there is minimal difference between DCHP and Static.

Streaming pictures from the MBL is okay it’s bad when transferring of large amounts of data to or from the MBL.