MBL Share flipped from NTFS to FAT

I created 2 private shares and a User on a brand new MBL 2TB. I mapped the two private shares to P: and W:  and the public share to Z:

Prior to copying any data onto any of the shares, when I right-clicked on any of the 3 shares in Computer (Win 7) and selected Properties, I saw 16.3GB used, 1.79TB Free, Capacity 1.80TB and File system NTFS - same data for all 3 shares.

After copying only 13GB of files onto the share mapped to my P: drive, this drive now shows 268GB used, 637GB Free and only 906GB for the total capacity - also, the file system now is FAT.

I’ve never seen a file system change from NTFS to FAT simply by copying data onto the drive. Also, there is only 13GB of files copied to the drive by me  + whatever files were preinstalled by WD (approx 16GB or so of software, etc.). So the figures for space used / available that’s now being displayed for the P: drive cannot possibly correct.

Is there a way to fix this? I don’t see anything in the manual about needing to format the drive after creating shares. Do I need to format each of the shares?

BTW, the 2 shares that I have not copied anything onto still each show 16.3GB used, 1.79TB Free, Capacity 1.80TB and File system NTFS

Something doesn’t seem right - or I’m not understanding something about how this drive works with regard to allocating space to shares. I’m not sure which it is, but I’d appreciate some guidance here.

thanks

Hi,

In reality, the real file format the MBL uses is neither NTFS nor FAT. The mapped drives aren’t real drives, and I don’t know how Windows gets its information, but since in the end each mapped drive is just a folder on the MBL, they share the same amount of free space. I mean, if your Public share fills up your MBL to the brim, your private shares will be full too. I guess the most accurate estimate of free space on your MBL, without resorting to SSH, you would get by accessing the web interface and checking the meter at the bottom.

HTH

The actual file system flipping might be related to this issue: http://community.wdc.com/t5/My-Book-Live/How-can-I-increase-private-folder-size-Default-is-17-4GB/td-p/305556/highlight/true

rjm05 wrote:

The actual file system flipping might be related to this issue: http://community.wdc.com/t5/My-Book-Live/How-can-I-increase-private-folder-size-Default-is-17-4GB/td-p/305556/highlight/true

 

 

rjm05, thanks for posting this. The solution discussed in the thread you referenced involves stopping & disabling the WebClient service in Windows Control panel. While I don’t know enough about what WebClient does - or what applications may require it, stopping and disabling the service seems to have fixed the problem. I needed to first find my way to where to make the changes (funny how searching for “webclient” in windows help came up with nothing - I needed to search on another forum to find that info).

For anyone who needs to know - it’s in Control Panel / Administration / Services / WebClient.

Stopping WebClient was not sufficient for me - it was set to start manually and it kept starting (which has me concerned that something installed on my computer may need it and may have been starting the service). So, I needed to disable the service to at least test. Once disabled, I needed to DISCONNECT the mapped shares, restart the computer, reset the MBL using the reet button on the back, then re-map the shares (I was not able to re-map the shares without resetting the drive - although I don’t recall seeing this mentioned in the referenced thread).

Once that was all done, all of the shares showed the same values for space used, space available and total capacity and no more FAT file system anywhere.

I copied another 8GB of data onto the share that I originally had problems with and the file transfer speed was double what it was before.

If I don’t run into any issues running with WebClient disabled and manage to get all my data copied without further issues related to this, I’ll come back later in the weekend to mark this solved.

Thanks again, rjm05. Good find!

jr

Excellent! Glad it seems fixed :slight_smile: