MBL not showing

I’m really hoping someone can help me out and all help is appreciated.

I’ve just purchased a 2TB MBL and I’m having problems accessing it. I have gone through the installation process and everything seemed to go fine. Forced firmware update and installation successful messages etc.

The problem I am having is the MBL does not show under my Network list on my Windows 7 64bit laptop yet it is working fine on my Mac desktop. I have installed WD Link and the MBL shows in the Devices Found pane but when I select it there are no options in the Drive Map pane. I have tried to map the drive manually but it is not found when searching by name or IP address. I have spoken with WD Tech Support and they’re at a loss, fobbing me off with try contacting Microsoft.

Tried everything I can think of and done numerous google searches all to no avail.

HELP, I;m losing the will to live!!!

Sorry I should of added I have also tried disabling Windows Firewall and my anti-virus software to no avail. I can ping the MBL with no loss and the dashboard is accessible thorugh my browser. This seems to be a fairly common problem but I haven’t managed to find anyone that’s solved it yet.

maybe this?


1 Like

I have already checked that but many thanks for trying to help me out. Any suggestions or advice appreciated.

Open a CMD prompt.

issue the command

net use x.x.x.x

where x.x.x.x is the IP address of your MBL.

What happens?

1 Like

Thanks for your help. When doing as suggested I get the following:

System error 67 has occurred.

The network name cannot be found.

Thanks again

I’m sorry… I gave you the wrong command. Try

net view x.x.x.x

1 Like

No problem, I just really appreciate the help.

net view x.x.x.x gives:

The server service is not started.

There’s your answer.

The Server service is not started

… is pretty explicit.   You need to check the Server service on your Windows box and ensure that it is running.

1 Like


After starting the Server Service I was getting the error message, The network path was not found. So I did some digging and found a post on another forum saying the problem could lie in the TCP/IP NetBIOS Helper not being activated.

So I started that and lo and behold I have a very sexy MBL sitting in my network places. So happy its sorted it was driving me nuts. Thanks for all your help really appreciate it.


Awesome. Glad I could help!