MBL not discovering my Windows 7 PC for backup

This problem seems to have been discussed previously but I can’t find anyone who has solved it.

I want to create a safepoint backup on my MBL on my Win7 desktop. MBL only sees the two other Windows 7 machines on the network and not the one I want to back up to. I have gone through all network and sharing settings and they are identical on all computers yet the MBL doesn’t see one of them. It even sees my WDTV Live boxs shares. All 3 computers on the network can exchange files without issue. Any comments anyone?



On your Windows 7 PC make sure that you have installed the most recent updates from Microsoft, and that there is no a firewall, antivirus, or other security software that might be interfering.

All are up to date, have turned off firewall and AV and still no help BUT a little progress, I removed my windows login account password and “Discover” lists my computer and it has the windows logo on the side BUT clicking the icon it requests a user name and password. I have no idea what it requires here, I have tried all I know!