MBL file to big for file system now lost folder ! help please

MBL 2TB WDBACG0020HCN-SESN 3.5 Years old

Today I tried to move a video file from PC to MBL it gave an error something like ‘file is to big for file system’ the MBL is quite full but there was 70Gb free space and the file was only 400MB, tried with a few other files and the same thing happened.

So I did a software reboot, and this failed with error code 31001 timeout, I then notice ‘shared videos’ folder was missing, not sure when this went. So I depowered the MBL left it 5 minutes and put it back on, folder still missing, but the capacity of the drive is still the same - like the missing files are all still there but not visible.

I went to the media settings and did ‘rescan’ no different then ‘rebuild’ no different. went to the diagsotics and it failed the short scan.

I then made a new folder in MBL and it let me copy the video file I tried to copy earlier and it worked, so I still have the other smaller folders (shared music & shared pictures) but the big 1.5TB ish ‘shared videos’ folder is just missing although the capacity of the MBL drive suggest the files are still there.

I did look directly at the twonky server with the web interface and the videos are not showing there either

Twice I have tried to contact WD upport and both times I just get an error message, internal server error, so thats no help.

I really would like to recover this folder as it has a lot of video I want to keep, but if its lost is lost.

What should I do now…
is the MBL still usable, recoverable?
can I get the folder contents back (i dont really think they have gone as the capacity shows its still there)
or if can not get it back is the only alternative a factory restore?

Thanks for any advice.

An update,

Now I have lost the ‘shared pictures’ folder also. But I now have 2 new entries in the MBL one for shared videos and one for shared pictures, these are not the usual folder icons just a page icon with the word ‘file’ underneath, if you click them my pc does not know how to open them, so the file type is not recognised.

Quite anoyed if I have lost the photos, some memories on there which I dont think I have copies of everything elsewhere.

Can anyone offer any help, please ???

I am considering using the reset switch on the back of the MBL but will this erase the data, I read it may but cant exactly find the answer.

Also I am now unable to copy files to my ‘new’ folder again, video files give the same error on windows 10, the file is to big for the destination file systme (or someting similar to that)


I did the reset using the button on the back, it rebooted but the problem still persists.

So now I only have ‘shared music’ other folders are gone but capacity of the drive is unchanged like they are still there.

Now I think I have made the problem even worse, the web interface was prompting to do an update so I let it, it downloaded the files then started upgrading, quickly got to 10% then hung for a very long time then it jumoed to 60%, but it got no further and eventually came up with an error message saying it had failed it then said please wait and then it just went and I can not access it at all, through the web interface or anything, the drive does not show up.

I have again tried the reset, but no different. The lights are still on the front and the activity light at the back near the ethernet. Seems like this drive has had it now? Are they repairable? Still unable to contact wd support through the web page.

Update:: I left it switched off overnight and powered on again today, now the drive boots back up again after the failed firmware update, web interface says update failed and I should try again (but not going to risk that again). So I am back to where I was, lost the shared videos and shared pictures folders, although the web interface still says ‘status:good’ & ‘Usage 1.9TB/2TB’ so the files are likely still there but can not access them.

How do you contact WD? many times now I tried the support webpage, always the same response…

An internal server error occurred during your visit.

A system error was encountered during your request. If you need to contact us, please make sure to report the error number below to us.
Error number: 26928000
How to contact us: email or phone.

If you click email it just takes you back to the same form which again fails, The phone number I can try on Monday, but last time I called them there were no English speakers. Any help ???

I have read the guide about SSH and Putty, I have followed the guide and enabled SSH, downloaded Putty and configured it correctly so now I have acces to the NAS this way also (see [GUIDE] Fix Dashboard Errors 3xxxx

Not sure if its any help as I don’t exactly understand what I am doing, but is it worth trying /usr/local/sbin/factoryRestore.sh noreformat am I right in thinking this wil restore the drive without losing my files?

But before risking doing that now I have access to the drive using SSH is there a way to find out what is on the drive and be able to copy files back to my WIndows 10 laptop before trying the reset? Looked around and can’t find anything that I can understand as it seems quite an advanced thing to do.

Still unabe to contact WD, really hoping for some advice.



Here’s a working link for you to contact WD Support via email.

1 Like

Thanks, WD did contact me back after I sent them a faebook message.

I have sent them details and the report from the drive but still no solution offered as yet, if I don’t get a response soon I will try one/both of the following…

A restore without (hopefully?) wiping the drive… [GUIDE] Fix Dashboard Errors 3xxxx using… /usr/local/sbin/factoryRestore.sh noreforma

Or fsck /dev/sda4 to check the HDD which is detail in this post Data Volumes failed to Mount?!