MBL Duo Login not working


I set up my new MBL Duo a month ago, and yesterday I went into it and set up shares. I aslo changed the password so it was a little more secure. I also upgraded the firmware.

However when I tried to login today using the online " http://mybookliveduo.local/UI/login" url it is not accepting the password I set up yesterday. I have tried everything suggested on this forum. Swithced off the HD, then back on and pressed reset for 6 seconds, 60 seconds, and two minutes, 60 seconds with the power off and 60 seconds with the power cable in. I have tried shutting down and restarting everytihng, computer and HD. But the screen still comes up with my new username and a blank space for the password. I have entered the old, the oldest, the newest passwords, + tried leaving it blank, but it wont let me get into the dashboard.

I can log in via mycloud and see the files, plus everything shows up on my network, but I cannot log in to set up any more shares, or to manage stuff as the password is not being recognised.

How to I reset the password to get into  http://mybookliveduo.local/UI/login?


I don’t know if it will make any difference, but just use the IP address instead of that long URL.

Thanks I tried that, but still cannot get in to the dashboard. Is there no way to reset the password. 

The HDD works fine, the only issue is login. I logged in yesterday, changed the username and password for what I thought was my user ID not the machine id, and now I cannot log in at all. As I said above, I have used my first pw, the second one, and the one I changed it to yesteday, but no luck and I cannot see how I can reset this password.

Thanks again.

If you depressed teh reset button on the rear of the MBLD, then it has reset the password to factory configurations.  Look in the manual for the default password, because that is what it is using now.

Also, clear the cache on your computer’s browser.