MBL connection Problem - No Connection to Web - File Explorer or Wd2go


I saw a lot of similar topics but I couldn’t find any solution for my problem. If anyone can help me about the issue , I will be very gratefull.

I have been using My Book Live since 3 years and sometimes I had some problems to connect my device. The connection lost suddenlly and since 3 days I coudn’t do anything.

My Problems are:

  • I can’t connect via file Explorer.
  • I can’t connect via smartware - quickview softwares
  • I can’t open the dashboard.
  • I can’t connect via Web user interfaces of mobile devices.

Until now, ı have restarted device several times, I have tried to reset my device and have deleted device from my modem control panel.

There is green light on my device (sometimes blinking) still. The device IP adress is always same (as far as I know, I am not using static ip) and It didn’t change untill now.(
When I try to connect to my device via file explorer, I see 2 icons, (one of them is an icon like my device and another one is a computer and both of them labeled as “MYBOOKLIVE”).If I click to the computer liked icon, I got an error message, that says to me that my device is not accepting any remote connection. (in details it says that the device doesn’t configured for SMB).I have no idea how to make this configuration.

Thanks for your support and help,

Have you tried resetting your unit by holding the reset switch with a paperclip?

Thank you for your reply, Yes I tried reseting my unit by holding reset buttun 4 sec, or 20 sec. But my problem still continues.

I’m in the same situation. The IP address you still see it’s probably a left over from the router, my drive is dead too, can’t get it connected to anything, doesn’t seem to get an IP address at all. I tried everything imaginable. I hope they didn’t push a software update that killed our devices.

I’m having the exact same problem. My drive was working fine, attached to my router, just a few days ago. Now it no longer shows up on my network. The led lights on the ethernet port look ok, one is steady on and the other blinks away as you’d expect. I cannot tell if there are other problems because my front led stopped working years ago.

Like the other user, here’s what I tried so far:

  • tried rebooting router
  • tried assigning the mbl with a fixed ip address (based on mac address)
  • tried changing the cable
  • tried power off/on
  • tried reset holding the reset button 4 seconds
  • tried reset holding the reset button 30 seconds
  • tried connecting the drive directly to my laptop via ethernet cable, nothing happened.

It looks like the drive is simply not showing up on the network and it is not getting an IP address. What else can we do?