MBL bricked? Constant yellow LED, Dashboard working, but "not enough space" left on device

Got myself a MyBook Live some days ago.

After the initial setup i also tried to update the firmware which resulted in the loss of the UI/dashboard (as reported in several threads on here).

Because i had ssh enabled i was able to access the device using mac osx terminal and filezilla. So i tried to manually update the firmware from file (followed the instructions from th board and kept the computer connected and terminal running). The while led was on for several hours so i tried rebooting the device. The UI was still inaccessible, but the device showed up in my local network (and mac osx finder).

After the latest reboot (forced reboot because the led suddenly turned red) the MBL started to show the blue and then the yellow LED (which is still on), but i was able to

-access the device using the static IP i assigned when first setting up the device

-access the UI and change name, network settings etc.

However, i am still unable to

-run utilities (communication error 5657, although both the MBL and the computer were connected to the router via lan cable; Also, the network LED on the MBL and the router told me that there should be a working connection)

-update firmware (“Device does not have enough space for upgrade.”, although the HDD is still empty)


-whenever i try to login to the UI after a reboot it behaves like it was the very first time being connected to the network (i.e. choose language and accept the terms of use)

-i am able to shut it off via UI, but im unable to complete the reboot process, thus the UI keeps showing the “dont close this window” warning

-according to the UI, the status is “bad”

Is it possible that some boot script got messed up and now the device is trapped in a loop?

As i said, im able to access the device using FTP and/or terminal, so i should be able to replace the corrupt file (if there is one and if thats even possible).

Also, is it possible that the read/write permission for certain files changed and if thats the case can i change it back via terminal?

Thanks in advance

Sounds like the firmware did not installed correctly, if you can just replace it for another one.