MBL and Windows 8

Since I could find only one or two posts from people upgrading their PC to Windows 8, I believe we need to talk this over…

In my experience, Windows 8 in the device section tells me that for the MBL device there is a “Driver Error” also called “Code 10”… this means that while one can access the files in MBL, the device is not fully “recognized” by Windows 8… so for instance, if I want to use brand new Windows 8 Store WD App, it does not recognize the presence of MBL (on a further note, something similar is happening to WD TV Live 3rd generation, which appears as “Not Certified for Windows”…)

I really hope something can be done about this situation…

Download the SES driver from the download section and install it. Worked for me.

SES driver does not work… tried that over and over again…

Anyway, I would like to take the chance to specify and correct my post:

MBL device works properly under Windows 8 Pro , and I am able to do everything just like I used to do in Windows 7.

The only issue is that, under the Device Manager (from the Control Panel) the state of the device appears to be “Unable to start the device (Code 10)”. The driver used is version released on June 8, 2011 by WD.

This is coherent with the fact that the device is listed among the Devices available under “PC Settings” with the message “Driver Error” and consequently it does not appear among the Devices on the Charm Bar.

I believe that it would be a great loss not to integrate WD MBL in the Windows 8 environment, taking advantage of the possibilities given by Charm Bar “Devices” or “Sharing” buttons.

As I said, something similar is happening with WDTV Live, which in the “Devices” page under “PC Settings” appears to be “Not Certified for Windows”, and does not appear when I use the “Devices” button on the Charm Bar to take advantage of the “Play To” function (although, for instance, with “Truelink +” app it does appear among the “Play To” devices, but not on the Charm Bar under “Devices”, and similarly I can use the “Play To” function from Windows Media Player from the Desktop)… since I am also beta tester for WD, I still need to try the new WD TV Live (Gen3) Beta FW to see if there are some improvements.

On the whole, I believe that for both devices there is an issue with their drivers (class drivers perhaps) not up to date for the new OS.

As for the WD app on the Windows 8 Store , I just realized that it is not meant to be neither for WD My Book Live nor for WDTV Live, since both divices are not recognized by the app, and are not even listed as those working with the app… this, of course, makes me very sad, since I was expecting WD to update their apps in view of the arrival of Windows 8.

I really hope someone, using MyBookLive (or WDTV Live) with Windows 8 may confirm or share something more about this, so that we can help WD to address the issue…

1 Like

Installed Win 8 and what  dreadful experience that was.

I proceeded to set up my MBL and also downloaded the WD app from the Windows App Store. Extremely disappointed that it does not work with MBL as I have all my photos stored on it and it would be nice to have a “native” app.

I am having a similar experience.  I recently received a new device from WD on RMA mainly because I called regarding this one issue.  After reading the posts on this thread, I installed the SES drivers.  I checked my device manager and everything looked like it worked.  I rebooted my computer just to see what would happen.  I now get the old error back again and repairing, uninstalling and reinstalling SES does not do anything.  I guess I should not have rebooted, but how realistic is that.

Anyone have any other ideas?

I am having the exact same issue as NicoPizza except that I do not have a WDTV.

Seems to be affecting people using the 64bit version of Windows 8. Win 8 32bit is fine for me, but Win 8 64bit has driver issues.

I have the same issue with 32 bit Windows 8.

Anyone figured this out yet?  We just got a Win8 computer (64bit) and device manager has the ! triangle.  I’ve tried everything without sucess.  I have a Win7 PC from work and it mapps MBL just fine.  I really need this to work with Win8 to manage my MBL files.

I’ve had no luck fixing this error. I’m choosing to ignore it. Everything seems to be working fine though. I have connectivity through Chrome to manage any administrative tasks and my TV and Blueray are connecting through DLNA with no issues. No luck with iTunes though. I’ve given up on that too.

Thanks but it seems since the firmware update (updated a few days ago) that even my Win7 box is having a hard time staying connected.  One thing is the WD2go on my Android tablet, my Android phone and WD2go.com works fine.  WD2go.com I can do administartion suff but it is painfully slow.  I’ve always like WD products but this one I’m about to take outside and show it the business end of my shotgun.  WD should be ashamed of this software package.  It’s needs a total redesign to make it better.  I’m wondering at this point if I should have waited and got a Segates network drive.