MBL and Smartware

Hi, I recently upgraded my modem/router to a Belkin Play Max. I shut down my MBL when I did this and have reconnected it. Now when I right click on my smartware icon I no longer get options like Dashboard only the option to open smartware. When I open smartware I can no longer see MBL {where I have a 200gb smartware backup} on it.

MBL shows on my network page and I can open it fine. I can manually open the dashboard by typing mybook on a web page because it remebers the IU form the last time I was there I can see my smartware backup discription, make changes to settings and so on in dashboard. I tried using the disc again [already used and sucessful on first installation only difference is the modem/router] and it tells me it cannot discover MBL. I find this all confusing because as I said I can see MBL in my nework page and can open it and access files yet I cannot discover it? Thanks for your help.

Have you tried using the disk that came with the drive?

Yes tried the disc. It worked the fist time I set it up the only difference is I shut it down to upgrade to a new router. Now the disc says it cannot discover it. I think its because it has a new IP address or somthing and I dont know how to fix it. I want to use the smartware program but it no longer shows in smartware. Why is this program not recognising its own hardware?

You can download the Iso image for the MBL and see if it works. Get it  here

Reply went to my above post for some reason

Sorry had trouble posting before. Ok I downloaded iso from above link and burnt it to a cd and ran it. Still did not discover MBL. So far I have tried original cd, software found on the MBL and new downloaded software with no luck. The original software did discover the first time I used it so I am guessing it has something to do with the new router or the new IP address?

The software could be easily blocked by firewalls, please check your configuration. You have options to map the drive manually no software required. Get the info  here on how to.

Hope this helps.

Your post is blank , if using IE9 check this thread for more info:


the icon in the notification area will only report temperature, status, free space, etc, if your DNS knows to resolve http://mybooklive to the actual IP that your new router has assigned to the drive.

Is your new router handing out DCHP, or did you reserve an IP for the MBL?  Can you create an entry in your router’s DNS that properly maps that URL internally back to that IP?

I just went into my PC’s network TCP/IP settings and put in the google DNS and didn’t even mess with my router’s DNS.  Worked for me.