MBL 2To data gone but here

For some unknown reasons I lost years of video archive on my MBL yesterday.
The setup:
Synology NAS mapped to shared folders on the MBL:
/Movie/MovieMBL(mapped network shared called Videos)

parted
GNU Parted 2.2
Using /dev/sda
Welcome to GNU Parted! Type ‘help’ to view a list of commands.
(parted) p
Model: ATA WDC WD20EURS-63S (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
3 15.7MB 528MB 513MB linux-swap(v1) primary
1 528MB 2576MB 2048MB ext3 primary raid
2 2576MB 4624MB 2048MB ext3 primary raid
4 4624MB 2000GB 1996GB ext4 primary

I first checked as previous posts like @TonyPh12345 suggested 3TB MyBookLive is holding all my data hostage

I tried “fsck -y /dev/sda4” -y for auto fix. It founds a lot of error:
"/dev/sda4 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes

Running additional passes to resolve blocks claimed by more than one inode…
Pass 1B: Rescanning for multiply-claimed blocks
Multiply-claimed block(s) in inode 4177921: 4259323
Multiply-claimed block(s) in inode 4183569: 4259323
Multiply-claimed block(s) in inode 8356180: 9501688 9501689 9501690 9501692 9501694 9501695 9501704 9501706 9501707 9501712 9501714 9501715 9501720 9501724 9501624 9501628 9501630 9501631 9501657 9501671 9501676 9501677 9501678
_Multiply-claimed block(s) in inode 8356183: 9501620 9501621 9501622 9501623 9501562 9501563 9501564 9501568 9501572 9501580 9501581 9501582 9501592 9501593 9501596 9501597 9501598 9501599 9501609 9501610 9501611 9501612 9501613 9501614 9501615 9501616 9501618 _
etc…"

then:
/dev/sda4: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda4: 37954/30355200 files (4.8% non-contiguous), 20830048/30453104 blocks
MyBookLive:~# fsck.ext4 /dev/sda4
e2fsck 1.41.12 (17-May-2010)
/dev/sda4: clean, 37954/30355200 files, 20830048/30453104 blocks

Then I restarted it:
MyBookLive:~# reboot

I recheck the login messages:
MyBookLive:~# dmesg | tail
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) on device 9:1.
Freeing unused kernel memory: 448k init
Disable EMAC EMI Fix
eth0: link is up, 1000 FDX, pause enabled
EXT4-fs (sda4): mounted filesystem with ordered data mode
eth0: no IPv6 routers present
_Adding 500608k swap on /dev/sda3. Priority:-1 extents:1 across:500608k _
svc: failed to register lockdv1 RPC service (errno 97).
Calling led_set_blink with value x

From my Synogoly the folder seems mapped but empty, I unmount on the NAS the share from MBL try to remount same: can mount but empty.
I tried to mount on my mac with smb or afp or ftp, it mounts but when tried to browse content it disconnects.

I tried to create a demo shared folder on MBL and mapped on the NAS and my Mac, and put a sample file it works and accessible.

I unmount the required shares again then run:
MyBookLive:~# fsck.ext4 /dev/sda4
e2fsck 1.41.12 (17-May-2010)
/dev/sda4: clean, 37964/30355200 files, 20830057/30453104 blocks

That made me think that the MBL is working “properly” but my previous shared show no size in the web interface of the MBL 0 out of 2 To.
I thought the data where gone, but not:
MyBookLive:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/md1 1.9G 955M 870M 53% /
tmpfs 5.0M 0 5.0M 0% /lib/init/rw
udev 10M 6.7M 3.4M 67% /dev
tmpfs 5.0M 0 5.0M 0% /dev/shm
tmpfs 100M 4.2M 96M 5% /tmp
ramlog-tmpfs 20M 3.8M 17M 19% /var/log
/dev/sda4 1.9T 1.3T 588G 69% /DataVolume

As you can see the datas are here because 1.3T is used. I start to get lost so:
ls /DataVolume/lost+found/
#10444801 #10445120 #16711682 #4183104 #4183263 #4183289 #4185955 #7311872 #9432802
#10445108 #10445122 #4177924 #4183257 #4183264 #4183294 #4190426 #7311874 #9432804
#10445112 #12533792 #4183098 #4183259 #4183268 #4183354 #6267248 #8355990
#10445118 #12533795 #4183100 #4183260 #4183269 #4183552 #7311394 #9432800

From there I have no ideas what do to recovers years of videos archive.

Any help or suggestions would be so much appreciated.

Hi,

I have not try this setup yet. Let’s see if any of the users can share some information about it.

1 Like

Above all even the diagnostic tools can’t be run and asked to contact the support after few seconds. Getting very disappointed!

Got contacted by support: long story short warranty expired but the MBL works, data are here but can’t access them.

:frowning:

Do not have much to say. However, if you know any Linux Gurus, they might be able to help.
These boxes run Debian Lenny.

In case you have to take out the drive to connect it to another PC via USB:

  • Win/Mac will need an app to see Linux partitions
  • Linux machine should be able to mount drives just fine. You can also use a Linux Live CD.

To take out drive see here:

And last, in the future, do not forget the importance of backups.
I personally went thru the same years ago, ever since, 2+ copies of important files at different media/server/PCs/etc.

Thanks but basically the MBL “works” when I create new shares, that maybe my last option unless I find a recovery option.

Thanks for the hint!