MBL 2TB will WD DLNA unstable

I updated my new MBL 2 TB to the lastest firmware (can’t confirm version number because I can’t access the dashboard), and switched to the WD DLNA server; however, my samsung tv says it can’t find media.

Oddly, the samsung tv will let me browse the folders and see the media but aborts 90% of the time when I try to view a movie. I have updated the firmware on the Samsung to the latest version too.

I chose to use the WD DLNA after multiple issues with Twonky. BTW, Twonky worked fine with my nexus 7 while the WD DLNA doesn’t work at all with it.

I can see the files on the MBL in explorer and even play them on several different computers with Media player, VLC, etc.

I have reset the MBL mulptiple times using the reset button, and I’ve reset the router multiple times. None of my 12 other devices able to connect to the network/internet have issues - stability, speed, etc. The only thing that doesn’t work is the MBL.

I have uninstalled and reinstalled the WD software by downloading the latest version. I was able to access the dashboard for an hour or so, but now I get a “connection to the server was reset” in both Firefox and Chrome.

I set up ssh, and previously setup an ftp connection. I can’t connect via ftp using Filezilla either. Because I can’t access the dashboard or establish an ftp connection I can’t post a log.

The problem occurs wired or wirelessly.

Everything worked great for a few days after updating the firmware and switching to the WD DLNA server, but now the MBL is unstable to the degree it’s unusable.

Lastly, I am still able to move, delete, and add files in windows explorer even though I can’t access the dashboard via a shortcut or typing the address directly into the browser. Clearing browser caches, as expected, has no effect.

Light is flashing green on front, and when I reset the MBL the led progresses through the color changes as described elsewhere in normal fashion.

I’ve got a DIR-615 Dlink router, all the systems I’m using to trouble shoot this are Windows 7. I’m not sure about my router specs, but I can use my fiber optic connection to download a flick in 25-30 minutes, so bandwidth doesn’t seem to be an issue. I can stream to Android and Apple devices seamlessly.

I even reserved an IP address for it to see if that would help ( but disabled the reservation as it had no effect.

I can log in with putty, but don’t know where to go from there to address this issue.

I’m out of ideas.

Any help is much appreciated.

Go into Twonky Setup and, under NETWORK, change the option “Restart on NIC changes” to OFF.

See if that helps.

Thank you for the suggestion.

However, I’m using the new WD media server and don’'t want to use Twonky as I had even more problems with it. Is there way to adjust settings for the WD server?

Update: the WD server is working this morning and I can access the dashboard. Last night before I gave up I unplugged the MBL, disconnected it from the network for an hour, and reset it manually again. This morning it seems to be working - just like yesterday; that is, until it stopped working…

I’m always perplexed when things just fix themselves.

Thanks again.