MBL 2TB and Time Machine... my story

For more than a year I have tried to use my 2TB MBL as the location from my Time Machine backups.

I have gone thru all the issues that most of you have described in this forum, I have followed many recommendations and solutions, I have upgraded my drive multiple times to the latest firmware as recommended, I have done a couple of factory restores, I have lost data, I have upgraded my Mac, I have tried wired connections, and I had kept my hope that someday this will work. Since the last firmware update, my time machine can’t complete a single back up, it hangs, stops, sometimes can’t find the drive, etc… My current backups are about 70GB estimated in 9 days…Unfortunately, I couldn’t trust backups of my data to my MBL anymore… So this afternoon I went to the Apple Store got a Time Capsule, installed it in lest that five minutes, and completed my back up in less that two hours… I will still use my MBL to store data, remote access, and all the god things that it can do, but not for time machine back-ups. This is just my experience that I wanted to share., Beside this time machine issue, all my WD drives are great. 

Thanks for sharing your experience.  Have you tried with the latest firmware update, released 2 days ago?