MB Live IP Issues

I am having some troubles with my MyBook Live. I can’t see it registered through my router anymore. If I unplug the network cable and plug it back in, it registers for a minute under a weird IP My router operates under standard 192.168.2.X IP ranges. Cant for the life of me figure out why its registering under this IP. I have tried resetting it by holding a pin in the reset button on the back. Any help?


Hi, when the cable is connected to the network interface card (NIC) do you see a light? Have you tried connecting the drive to the Ethernet cable of the computer? Did you change something on your network recently?

169.254.x.x IPs are for interfaces when it times out due to not finding a DHCP server.
In a few words, the MBL cannot find you router which is the DHCP server.
Usually it is due to a bad port, cable, cable not completely plug in.

Now, how do you know if connects under, beats me. So you might have omitted some other info.

Tried replacing cable and trying different ports on router and no luck. I know it’s connecting under that ip because if I plug the hard drive into my PCs LAN port the MyBook Live shows up on my computer. When I access it that’s the ip it goes to and I can access it fine. Through the router it doesn’t register an IP. Called tech support and they couldn’t figure it out and said it needs to be replaced.

Any more advice?

There you go, that is the part that was missing.

  • So if you can access it via when connected directly to the PC, it means the unit is fine.
  • If cannot access it via the routers and see it under DHCP leases, even when you try a new cable or port, the issue could be the DHCP server part on your router. Give it a try.

Another option, since you know the router is 192.168.2.X, set MBL to static IP when you have it connected to the PC, just make sure it is not an IP part of the DHCP pool.

BTW, never seen a router with 192.168.2.x as default, it is usually 192.168.0.x or 192.168.1.x. Wondering if that was also modified. Not that it makes any difference though.

Just tried plugging my laptop direct to router and doesn’t work. Guess lan ports are toast. It’s from my ISP so that is why the range is like that.

Sent from my iPhone