Mapping a drive letter to My Cloud Public share

I had a Black Armor NAs that just died–2 years old.

I think I like this My Cloud 3T that I got yesterday, but I am having one bit of trouble…

I want to map a drive letter to the Public share.  On the old BSNAS, I was able to do this purely in Windows 7 using a shortcut to a cmd file containing

net use P: \DEVICENAME\Public

It is not working with the Mycloud.  Well, better said, it doesn’t work fully or right.

Here are facts…

the DEVICENAME does show up in Network as the name, yet a click on it opens to a folder named as the IP address.

-Same with the net use command…it open the folder, but \DEVICENAME has been changed into the IP address.

I am concerned with this since the IP is DHCP and will change at some point.  Clearly the system ‘KNOWS’ the device name as it is displaying it in the networks folder.  So why is it doing it–refusing to use the (NETBIOS/SMP?) computer hostname (and I do not know if “it” is Windows 7 or the discovery app)?

A corollary question…can the MyCloud be run without the Discovery sfw installed, i.e., as simply a server attached to the network?

Yes, the NAS can work without the discovery software. On Win 7 and 8, simply right click on a share in the network explorer and map that share as a drive.

To see the NAS, you need to have the file sharing and network discovery service on (automatically on for private networks, turned off by default on public networks)

jcarerra - Also, to alleviate any concerns about DHCP changing the IP, I would recommend you assign it a fixed IP on your router. Then it will always be the same IP (because it’s tied to your device’s MAC address) and that comes handy if you ever wish to set up port forwarding for ftp from outside, etc.

Is this what you tried, Start>Network>WDMyCloud, then choose Public and right click on it. Click on Map Network Drive. See image below.

MyCloudMap.JPG


Then choose a drive, Step. 1, and check the box for it to reconnect at logon, Step. 2. Be sure to click Finish. See image below.

MyCloudMapb.JPG


If this is not what you tried before, try it and see if it will work for you.

Posted by,
cat0w (USA)

An aside…when I came back to reply to the multiple helps (thanks), I had to relog in–except I could not.  The password, which had been created by and stored in a password manager, would not work.

No problem–do the request new password thing.

Wait 15 minutes–no email received.

Request it again.

Wait 15 minutes–no email received.

So I created a new account.

Not in a good mood due to this wasted 45 minutes so far.

Replies to begin momentarily folloing this…

Etupes wrote:

Yes, the NAS can work without the discovery software. On Win 7 and 8, simply right click on a share in the network explorer and map that share as a drive.

To see the NAS, you need to have the file sharing and network discovery service on (automatically on for private networks, turned off by default on public networks)

“simply right click on a share in the network explorer and map that share as a drive.”

Yes, but that misses my point about it always being “set up” showing the IP address as the computer name rather than the hostname.  Why won’t it use the NAME instead of the IP when it clearly KNOWS the hostname as that is what shows in the Network folder?

File sharing and network discovery are on.

Cybernut1 wrote:

jcarerra - Also, to alleviate any concerns about DHCP changing the IP, I would recommend you assign it a fixed IP on your router. Then it will always be the same IP (because it’s tied to your device’s MAC address) and that comes handy if you ever wish to set up port forwarding for ftp from outside, etc.

OK, I have done that.  I had the original Blackarmor one that way too.

cat0w, I understand the several way to do it, but am still puzzled as to why every window and mapping comes up using the IP address rather than the device’s hostname–which CLEARLY is being ‘picked up’ (known by the system) as that name is what shows in the Network folder.

My end objective is to not always have a drive mapped to the Public folder, but to have a shortcut on my desktop which will create the mapping as I need it.

I already have a shortcut to the Public Share on my desktop computer. See image below.

MyCloudSC.JPG


What I showed in my prior post can be done anytime you want to map it and it can be removed. I have done that.

If you already have plans to try and do it a different way then why ask us for help?

Posted by,
cat0w (USA)

jamescarerra wrote:

cat0w, I understand the several way to do it, but am still puzzled as to why every window and mapping comes up using the IP address rather than the device’s hostname–which CLEARLY is being ‘picked up’ (known by the system) as that name is what shows in the Network folder.

 

My end objective is to not always have a drive mapped to the Public folder, but to have a shortcut on my desktop which will create the mapping as I need it.

That’s odd. It does give me a named path and not IP (see below). Though I don’t have the regular My Cloud you have but have the EX2 instead…but I’d think this behavior would be the same. And I too don’t like to map to a drive…I keep a tiny shotcut icon to the drive on my taskbar and anytime I click it the particular share I created the shotcut to opens up looking like below screenshot.

NamedDriveLocation.jpg

 “If you already have plans to try and do it a different way then why ask us for help?”

 

Ah, sorry to have offended you.  You clearly did not recall from my very first post I said, "I was able to do this purely in Windows 7 using a shortcut to a cmd file containing

net use P: \DEVICENAME\Public
It is not working with the Mycloud.  Well, better said, it doesn’t work fully or right…"

and went on to elaborate.  I am sorry if you feel it is too demanding that I am

 

–not wanting to either keep a permanent mapping (which right now to my chagrin maps ONLY to an IP address, not the name–and which has not been addressed here in spite of my mentioning it several times)

 

–not wanting to regularly use a multi-step process as you described.

 

Showing me an image of an icon on your desktop tells me nothing about what it does or how.

 

Frankly, your reply seemed pretty unfriendly to me.

 

 

cybernut1, that image is exatly what I would have expected too, but if I either use the net use command or go through network>[dbl click DEVICENAME], the window that opens has IP instead of the hostname…

Instead of using net use and all that, let’s start afresh.

Do me a favor and can you first open Network and sharing center -> Change adapter settings -> rt-click and disable any wired and wi-fi connections first and then after they show disabled, rt-click and enable the same connections back (this is to close any open connections to My cloud that may have been persisitng).

Now go into your windows explorer (I have Win 7 so I know this’ll work in Win 7) and then put the following in the address bar: \<server_name><sharename> and then click Enter (of course substituting the server name and share name in those placeholders). Does the share open up as a named path or an IP address? You may have to click on the address bar once to see the path.

Paste a screenshot here of what you get.

1 Like

Well, folks, That worked just fine–it opened the share folder AND displayed the path with the Device name just as one would expect.

So, I decided to go try my shortcut again,which points to this cmd file:

net use P: \\DEVICENAME\Public
echo net use P: \\DEVICENAME\Public 
start explorer P:\
EXIT

 and an explorer window opens with DEVICENAME as the path.

I have no clue why before (and I did it numerous times)  that it always opened with the IP showing as the \target.  Perhaps you hit on a clue, that there was a connection still active that had been made earlier to the IP and it was just pulling up that.

Oh, there is one other thing:  I put

192.168.0.XXX  DEVICENAME

into my hosts file (which I can do now that I made the IP static).

That may be doing it as well.

Reply to: jamescarerra

 

_________________________________________________________________________

 

 Showing me an image of an icon on your desktop tells me nothing about what it does or how.

 

  _______________________________________________________________________

What happens when you click on a shortcut?

 

My shortcut to my My Cloud Pubic share opens it up and I see my contents. The shortcut was placed on my desktop when I set up My Cloud.

 

If you looked close at the images I provided in my earlier post you would see under Map network drive are, Copy, Paste and Create shortcut.

 

I have Windows 7 SP1 and I know several ways to view my My Cloud and the different shares.

 

Please let us all know how to create a shortcut that automatically maps the drive when you click on it.

 

Posted by,
cat0w (USA)

 

 

 

 

In the post preceding yours is this:

"So, I decided to go try my shortcut again,which points to this cmd file:

net use P: \\DEVICENAME\Public
echo net use P: \\DEVICENAME\Public 
start explorer P:\
EXIT

 and an explorer window opens with DEVICENAME as the path."

And P: is now mapped to the Public share on the My Cloud.

That is how.

I personally don’t even like to map it to a drive…I just use the path \ as-is and my shortcut points to that path and opens up the share anytime I click on it. And yes, disabling and then re-enabling the connections must have killed the connection to the server that was persisting (alternately a reboot should have done the same task).

I just don’t get the necessity of adding that entry in the hosts file. If you’ve made that IP static on the router then anytime you boot My Cloud, it will get that fixed IP just as you set on the router. Why set up a hosts file entry??

BTW, if my post solved your issue, please mark that post as solution and if you don’t mind, you can click on the little star icon in that post to give me a kudo for the solution. It’d be appreciated.

Certainly on the kudo.  I can’t mark it as solution because I had to create a new account when the first one would not log in and the site would never send me the recovery email.  Since I am not the original poster (to the system) I can’t mark it as solution.

I NEVER did get the password reset emails from them for the original account.

Aah okay, that’s right, you’re logged in as a different username and can’t mark it as asolution - only the original poster can. Thanks for the kudo.

Interestingly, this afternoon right around when you had login issues, I was having some login issues myself…despite using the password I used for weeks on this site. After I closed out the browser and reopened it, all was fine. Interestingly I had the same problem a few weeks ago when I first joined this site. I rememeber seeing last week or the week before that the main admin of this site (Bill_S) saying here that they’re looking into this - I think this isa recurring issue. It might’ve needed some kind of manual fix on the admins’ part and by the time I closed the browser and retired again, maybe it was fixed. This is that post from a month ago that I stumbled across recently ->  http://community.wd.com/t5/Forum-Feedback/How-to-sign-in-when-you-get-quot-An-error-has-been-encountered/m-p/705058#M2039

In my case, I emailed the mods and I only heard back from them days later, asking me to clear cookies, etc. before logging back :confounded: By then, my login issue seemed to have resolved on its own.

BTW, I don’t know if you saw my note on the hosts file. I don’t think you need it…but maybe you have a specific reason.

Interesting about the login issues.  maybe I should try the ‘forgot password’ route one more time on that account.

Putting the name/IP into HOSTS was just something I did while trying to sort out the strangeness.  When I get the notion, I will go take it out and see if things still connect through the name rather than the IP.