Map network share on DX4000 using windows System account

Hi

I have a problem where I need to map the public folder using the PC SYSTEM account user in order for the files to be served /access via a WCF service (or IIS). As mentioned, in a Windows service setup or IIS / web hosted setup this must be done as the call to the file uses the SYSTEM or IIS-USR account. Due to permission problems a normal mapping will not work. Just BTW - a normal “:windows explorer - map network drive” works fine for windows explorer copy and paste files etc - but not for an IIS/windows service file access.

I have several Seagate blackarmour 440 NAS drives and purchased this WD sentinel as a result of the suppliers having no stock of the seagate. Really regretting that now!

For each of the Seagate NAS drives I use the following to create a network mapping on server bootup:

1 - create a task in task scheduler that runs a BAT file (net use z: \NASDRIVE\sharefolder /persistent:no)

2 - set the task to use the system account when it executes

It works 100% with the Seagate NAS’s, but using the exact same method with the DX4000 simply does nothing.

It logs the error:

Task Scheduler failed to execute task “\Map X Drive” . Attempting to restart. Additional Data: Error Value: 267014.

which simply means the task failed to execute.

I’d really appreciate anyone helping me on this as soon as possible.

Thanks

Warren

Not sure

I went to a command prompt and type net use z: \wdbeta\pictures /presistent:no and command completed successfully

How did you create the share?  Using the wizzard in the dashboard?

Can you map your share in explorer?

Hi Gramps,

The command prompt works 100% for me too, but using the same command prompt in the following cenario it fails.

Try this:

Create a .bat file with "net use z: \wdbeta\pictures /persistent:no "

open task scheduler and create a new task

in the actions tab, select new, run a program, and browse to the .bat file you created.

then, in the general tab, change the user account to run the task to “system” and run with highest privileges.

The click ok etc and try to run the task.

To answer your questions:

The share is the general “public” folder share with “everyone” having access.

Definately can map the share in explorer, but due to a system account service trying to access the file it fails (within the service). I have already tried to code in personation - that is logging in as another user in the code and trying to access the files that way, but to no avail.

As mentioned, the above procedure works 100% with Seagate Nas drives, just can’t understand why it wouldn’t work with Wd.

Thanks! looking forward to any help you can provide

Warren

i will poke around some later today.

In the meantime I gotta ask :)  Why persistant no?

The seagate prob work cause it is more than likely *nix* doing the sharing, so the answer may actually lie in the shae permissions somehow

This is as much time as I am going to waste :slight_smile:

Aparently and or no clue, but google says system does not have network access.

I have pinged and poked, defraged and refraged, asked everyone I know with a pocket protector.

http://stackoverflow.com/questions/182750/how-to-map-a-network-drive-to-be-used-by-a-service  is as close as I got,  I was able to open a system command prompt with psexec -i -s cmd.exe  but net use still did not work

But I tried net use user system and gave it the admin password and it mappedd.   You can play with that and try to script it if you like.  You have to dl the pstools psexec

Again I think the diff is nix vs windows on the mapping.

I have no clue what you are doing or why it has to be a system acount, but it is not a sentinel problem, it is windows server :frowning:

Hi again

Thanks for trying anyway.

Persistent to NO because, in the case of the system user account, even if it is yes it does not persist :slight_smile:

So i run the task every time the computer restarts

Yeah I also looked at that stack overflow question a while back. I’ll download the pstools and use their suggestion, see what I can come up with :smiley:

It must be a system account because the program accessing the files on the NAS is an automated program - so IT runs on a system account.

Anyway, I’ll also try RDP route and manually add a system account to the folder group - see if that has an impact. My last solution is to create a service that allows file access on the WD dx4000 itself - but what a round-a-bout route!

Thanks again for trying and if I find a solution I’ll post it here for other hapless programmers with this issue :smiley:

W