Many problems using a 2TB MyCloud with OS X 10.6.8

In general, my MyCloud system just doesn’t work. Or doesn’t work for long.

Setup: iMac running 10.6.8 and Netgear DG843G router. Brand new MyCloud with up-to-date firmware.

I have turned off the Sleep on the MyCloud.

Here are SOME of the symptoms:

  • When plugged in, WD MyCloud always appears in the “Shared” area in the sidebar, but attempting to connect to it always results in a “connection failed” message.
  • I can sometimes get to it via smb:// and sometimes via afp:// but it’s very unreliable.
  • For example, today I tried to connect to it via smb:// and the process got as far as “log in as Guest” and then a “connecting” dialog. That dialog stayed in the “Connecting…” state for half an hour, and couldn’t be cancelled. It stayed on screen until the computer was rebooted.
  • Then I connected via afp:// which worked, and I tried to copy a 300MB file from the MyCloud to a USB thumb drive. It copied most of the file until the Finder was saying “5 seconds remaining” and stayed there. The copy never finished and couldn’t be cancelled. Another similar file copied fine just a few moments later.
  • TimeMachine backups stall. When I come to the machine in the morning (TimeMachine backup is set to happen overnight) it’s trying to back up but not succeeding. When I tell it to stop backing up it never changes from the “stopping backup” message.
  • When I open the Disk Utility, it hangs with a blank screen and has to be Force Quit.
  • I set up a cron task to write to the MyCloud drive every few minutes. It last wrote to the drive at 11:20 PM and since then the task has died with an IO error. Presumably the drive went to sleep somehow and never woke up?
  • I plugged a 2TB WD external USB into the MyCloud’s USB port and nothing happened at all. Under USB devices in the GUI it just said “no USB drives found”.

Basically, my first experience with MyCloud has been 100% frustrating and negative.

I would really appreciate any help. Are there problems with my router maybe? Any clues gratefully received.


Have you tried performing a system only factory restore? This might help to set the settings back to normal and you can try setting the unit again.

Also check the settings on the router to make sure that the firewall of the router is not partially blocking the unit.