Making my iTunes Library run via remote access and improvement in transferring speed of media files

Hi fellow users,

I just purchased this NAS to give it a go in the area of personal cloud sharing and while spending 2 weeks of long transferring, I managed to get my iTunes media folder ready for use. 

Just a background of my intention, I would want to link my iPhone to be able to sync to one shared library saved in the NAS when im using my macbook pro or windows PC. So far this works well in my home network after 2 weeks of painful transfer, but I now stand before a wall to access the library remotely. 

I logged in to my remote account via and I am able to see my personal folder where my stuffs are kept as per normal. However, when I point my iTunes to link to the same library file, iTunes came with this message.

“The iTunes Library.itl file is locked, on a locked disk, or you do not have write permission for this file.”

I believe I am not understanding the remote function well to handle this. At the moment, I can think of these few possibilities.

1.My iTunes file is not set to give full permission over remote access (which I have no idea how to grant)

2.The NAS is restricting such access to open the iTunes Library remotely by encrypting with my password. I think that it has to do with the logging in to my WD2Go account then another layer personal folder encryption. 

3.The iTunes is simply not allowing this method of access due to protection against piracy or its other policies are being infringed in the process.

These are just speculations, it may be right or wrong altogether.

Another thing I might require assistance is the problem of slow transfer speed. I know there are many other people posting this issue in this community, but I would like a personal attention on this case.

I am using TP-Link WR1043ND Wireless N-Router that links to my WD MBLD. This is placed in the storey above me at home. I also have an Aztech Homeplug AV Powerline system (Aztech HL115EP as master and Aztech HL110E as slave) linked to my router as well that is connected to me directly to my PC and MacBook in my room, hence I am able to access to my WD MBLD directly via power line and wirelessly within my home network. 

However, with the advice from WD staff to update my firmware, my transfer speed is still capped below Mbps (average between 800-Kbps at the moment) for both methods of communicating with WD MBLD. On my router, I also portforwarded WD MBLD to see if it has any improvement on the speed but it is capped below 1Mbps. I can only point 2 possibilities, my router is not configured correctly, or the WD MBLD is not allowing higher data transfer speed.

Although I have just corresponded with the WD staff again on this issue, I would like to see how the community would advice me on this issue as well. I am not that well-versed in this field but I am open to criticism on what I have done wrongly.  :smiley:

first thing first…

did you already enable the iTunes Library on the MBL UI

try rescanning and see if you still have the same results

I don’t regularly access my iTunes from WD 2Go but I don’t see a reason why it should not work

Yup, it is enabled. I tried accessing the library file by point iTunes from both Windows and Mac to the exact file and it did not load.

“The iTunes Library.itl file is locked, on a locked disk, or you do not have write permission for this file.”

WD 2go uses WebDAV as the connection protocol.   You can’t access iTunes for syncing via WebDAV.   Apple doesn’t support that functionality, nor does WD.

Ah I see. I got a hunch there is a protocol infringement if I did that.  This sharing of iTunes Library is still okay if I am using it within my home network right? 

But I do wonder, when you guys purchase the NAS infrastructure, did you ever consider this idea to access itunes remotely? 

Nowdays, that’d be redundant.    Apple already provides cloud sync functionality.

I see. Okay while the first question is impossible to solve now, how do I improve the speed further? 900 Kbps is really the slowest rate out of the pool of complainants I came across.

I’d start from the basics and see what kind of speeds you achieve if you directly connect your PC to the MBL via a Gigabit-switch port.

If your MBL is already plugged into a LAN port on your Router, then plug your PC into another LAN port on the same router and see what speeds you get then.

I cant connect my PC to the router since its one storey difference and my PC is a desktop. I did tried it out on my Macbook once and it seems faster, but I could not tell the exact speed it was transferring. I am wondering is this issue happening on my PC solely? The Macbook seems to connect to the network faster and by wireless connection to the NAS, it takes significantly lesser time than when i transfer on the PC wirelessly. My PC is 2 years 4 mths old.

My PC is much older, but performs much better. I think, more than likely, it’s a combination of Wireless and Powerline network as opposed to straight ethernet. You might try ordering a long cat 5e cable, which costs less than 30-40 dollars, or just lug your pc upstairs.

Okay, I may consider that as well. Thanks! =)