Make PR2100 visible under network in windows 10?

So my question is are there any other methods at all to make PR2100 visible under network in windows 10 besides enabling SMB 1.0?

The moment I enable that it pops into view and allows me to see all the shared folders at a glance, but from what I read it’s not advisable to have SMB 1.0 enabled.

I mapped my own share no problem and it stays visible in the directory tree, but I’d like to see the whole My Cloud PR2100 especially since I can’t map the public shares.

Any tips?

TIA

Hi LoneWolf_53,

You can refer to the link provided below to resolve your issue with WD Mycloud PR2100.

https://support-en.wd.com/app/answers/detail/a_id/26826

Thank you for the response but your link does not address my question.

I have no problem accessing My Cloud with a user account, and have in fact mapped my personal share successfully.

What I don’t like is that I can’t map the public shares or have My Cloud appear under “network” in Win 10 Pro as my other network attached PC’s do. It will if I enable SMB 1.0 but if I disable that, the only way I can connect is to go to file explorer and enter \MYCLOUD.

When you do that it appears under “network” but goes away as soon as file explorer is closed.

I’d like a work around for that if there is such a thing.

Network Browse is a feature of SMBv1 which has been disabled in Windows 10 by default

This link explains all the details.
https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows-10-rs3-and-windows-server

image

I am aware of that information, as my posts have clearly indicated.

What puzzles me is why can I see my other networked PC’s without SMB 1.0 activated, but not the My Cloud connected to the same network?

After all a NAS is but a tiny computer without a keyboard, mouse, and monitor directly attached.

Seems like a design flaw to me.

Are you saying that you see OTHER SMB type products on your Windows 10 Computer under “Computer” which is Network Browse in Win Terms? In the screenshot below, the C6300 is a NetGear Gateway Router with USB drive attached. It will only show up on Windows 10 with SMBv1 enabled.

can you share a screenshot?

Not under “computer” that shows all the computers on my network, but in the directory tree under “network” when it’s expanded all the computers are listed there, plus the My Cloud if I enter \MyCloud into file explorer browser.
I’d love it if the My Cloud would remain there but once you close the window it’s gone. If SMB 1.0 is enabled it remains there.

Don’t want to put up a screenshot as I don’t want my computer names made public.

I’m fairly certain I’m stuck having to enter \MyCloud into file explorer when I want to see all the shares in the unit but I’d be much happier if it were possible to map the whole unit as a drive letter.

I am also having a similar problem. I’ve been using a regular MyCloud single bay unit for a little while now, and under my network folder, if I right click, I get an option to “open” which then shows my shares/public folders and my USB drive.

I just obtained a PR2100 and it also shows up in my Network, but if I right click on that, I don’t get the OPEN option? So I’m not able to see my folders. Can anyone assist on how to access my shares from Windows 10?

What I wound up doing in the end is using file explorer, enter \MyCloud where MyCloud represents whatever you are calling your PR2100 (note two back slashes preceding your cloud name) after which you may have to login but it will show up under “network” section of your directory tree.
I then right clicked that entry and selected pin to quick access. Now any time I want to access those shares I can just double click the icon in quick access.

I’ve also done this, and it does work according to plan, BUT I was hoping to get it to just show up under the Storgae section or even the Computer section.

I also just had to set up a new Win10 PC on my network, and both of my My Clouds show up just fine, but 1 PC allows me to right click and have multiple options, and the other PC displays the wrong icon and diesnt give me many options (only real option is to go to device webpage). I cant remember if I installed software when I initially set up my single bay unit whic may have configured things properly from the start…?

Unfortunately it is what it is and with SMB 1.0 file sharing support disabled in Windows (as everything I’ve read says to do for security) our MyCloud simply won’t show up under network in the directory tree.

As for your other issue with the new PC I don’t know what is wrong there, not to mention you aren’t talking about the same product I have, as in PR2100 2 bay My Cloud Pro.

Mine works fine without any additional software.

Thanks LoneWolf, whats strange is that it WAS working fine before. I have 2 My Cloud units, a single bay unit (2nd Gen) and a PR2100, and they show up differently under my Network page, AND my single bay unit shows up differently on my laptop than it does on my desktop?!

I’ve successfully added all my drives and shares to the “Quick Access” menu, and that works fine, but was wondering why… I’m not gonna waste any more time trying to figure things crazy thing out… I have access via the “quick access” menu, and for now thats good enough.